Garageband painfully slow to open

Discussion in 'Mac Apps and Mac App Store' started by gonnabuyamac, Feb 29, 2008.

  1. gonnabuyamac macrumors 6502

    Joined:
    Sep 26, 2006
    #1
    After updating to 10.5.2, GarageBand takes *minutes* to open! Is anyone else having this problem? I even tried uninstalling and reinstalling GarageBand - then I did an Archive and Install, and that didn't work either.

    Also, on some websites and in iTunes, when I scroll, now sometimes there are white flashing bars and boxes (they go away, but it's not smooth at all).

    This update made more problems for me than it fixed. Though I am happy to be done with that transparent menu bar. ;)
     
  2. GanleyBurger macrumors regular

    GanleyBurger

    Joined:
    Feb 25, 2007
    #2
    GB woes

    I'm still using Tiger 10.4.11
    SR 2.4 Core 2 Duo
    17" MBP
    7200 RPM drive
    4 gigs RAM

    And yes, it takes long to open, build.

    The worst part for me is while playing back 5 tracks (2 virtual instrument, 3 loops) and trying to scroll through and preview loops, the machine lags.

    WHAT???

    I know that MACs are more known for being stable as opposed to being lightning fast and crashing, but this is nuts....:mad:
     
  3. iFool macrumors member

    Joined:
    Feb 5, 2008
    #3
    I was in the apple store and even a 8 Core Mac Pro takes an age to load it. Its takes decades on my eMac
     
  4. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #4
    Same thing here. It always took a wile to load on my Mac, but never as long as it has been lately.
     

Share This Page