Garageband slow to open with SSD?

Discussion in 'iMac' started by jazzer15, Jan 20, 2016.

  1. jazzer15 macrumors 6502

    Joined:
    Oct 8, 2010
    #1
    I was wondering if someone with an SSD on a 2015 iMac and who uses Garageband could tell me how long it takes to open the program. I have a 512GB SSD and I noticed that it can take 7 or 8 "bounces" to open sometimes, while other times it will open after one. Most other things open almost instantaneously, so I was wondering if it is typical of the program.
     
  2. JustMartin macrumors 6502a

    Joined:
    Feb 28, 2012
    Location:
    UK
    #2
    Do you have a lot of plugins/instruments to load. My reasonably vanilla Garageband takes two bounces to load and that's on a late 2012 Fusion.
     
  3. jazzer15 thread starter macrumors 6502

    Joined:
    Oct 8, 2010
    #3
    No, which is why it is a bit perplexing when it does it (which is only sometimes). I just have the standard set installed and I have an empty project as the most recent. Is there a way you know of to completely delete and reinstall the app? It is a new system and I am a little tempted to just do a clean OS install just to see what happens, although it would be a bit of a pain to set everything up again.
     
  4. Erdbeertorte macrumors demi-goddess

    Joined:
    May 20, 2015
    #4
    It takes less than a second on mine, so almost instantaneously like you said for the other things.

    What version of OS X and GarageBand do you have installed?

    And what iMac is it? 5K, 4K or the low end 21.5"?
     
  5. jazzer15 thread starter macrumors 6502

    Joined:
    Oct 8, 2010
    #5
    It's a brand new iMac 5k, i7 running the latest update of El Cap. and the latest Garageband. FWIW, the app runs fine.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    When it's slow, check the Console to see if something else is going on.
     
  7. jazzer15 thread starter macrumors 6502

    Joined:
    Oct 8, 2010
    #7
    OK, so just because I didn't have much on the computer yet, I erased the internal SSD and reinstalled the OS. I reinstalled Garageband and it is still showing the same behavior. The program usually opens very quickly if I have opened it recently (maybe it is cached?), but this morning it took 9 bounces to open (not really worth pulling my hair out over, especially since it seems to be running fine otherwise, but it doesn't seem quite right on a new 5K, i7 with the App installed on an internal SSD).

    Below is the screenshot from the console. It seems like something isn't quite right, but I don't know enough to understand what this means. If anyone has an idea, it would be helpful.

    Of course I can call Apple tech support (and I may), but it can sometimes take a while to get to someone at a high enough level that they might actually be able to help.

    Any help is greatly appreciated.
     

    Attached Files:

  8. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #8
    Your caching theory is possible. I've noticed the same thing on other apps, such as MS Office.
     

Share This Page