garageband = sound delay

Discussion in 'Mac Apps and Mac App Store' started by j5uh, May 7, 2007.

  1. j5uh macrumors member

    Joined:
    Mar 13, 2007
    #1
    I hooked up my guitar in the the mic port on my Macbook with a mono adapter to ¼” adapter. Than another adapter that was coming out of the headphones to the mixer which the mixer was hooked up to the PA system.

    The guitar sound effects come out nicely but there is a slight delay when I strum!!! How do you fix this? I wanted to use this for my band but I just couldn’t perform with the delay.

    I’ve even tried no-effect and there’s still a SLIGHT delay. =( how do you fix this?!?!
     
  2. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #2
    Odd, I've never noticed an appreciable delay, but it might depend on what hardware you're running. However, OS X doesn't have incredibly low audio latencies like some OSes, so you're probably better off just getting a decent dedicated effects box (like a Line 6 pod or something).
     
  3. emotion macrumors 68040

    emotion

    Joined:
    Mar 29, 2004
    Location:
    Manchester, UK
    #3
    That's just latency. Core Audio is not to bad with latency but you're always going to get it. An exernal audio interface might fair better than the on board Apple audio.
     
  4. bentley macrumors 6502

    Joined:
    Mar 20, 2005
    #4
    Depending on the software/hardware you use you should be able to tweak your latency down. It will increase a burden on your hardware but should be manageable with light software.
     
  5. KettyKrueger macrumors 6502

    KettyKrueger

    Joined:
    Feb 17, 2007
    Location:
    UK
    #5
    This has happened to me a few times. I find that if I close GB completely then re-open it, it does the trick nicely.
     
  6. SuperSnake2012 macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #6
    Yeah, I have this problem occasionally when recording with a lot of tracks. Just completely closing it and reopening it fixes the latency.
     
  7. Dharma Logos macrumors newbie

    Joined:
    May 8, 2007
    Location:
    Illinois
    #7
    There are two things you can do in Garage Band itself to minimize latency.
    1. Garage Band > Preferences > Audio/Midi: Make sure "minimum delay when playing instruments life" is checked.
    2. Track Info > Master Track > Details > Turn down the ducking slider.

    I don't have a latency problem myself, so I'm curious to know if turning ducking down would actually help.

    By the way, does anyone actually know what "ducking" is? I have no idea.
     
  8. daddyhodgepodge macrumors newbie

    Joined:
    Aug 28, 2011
    Location:
    new jersey
    #8
    garage band on ipad2 latency adjustment

    This delay on my guitar is driving me crazy. read all the reviews below but cannot resolve problem. I see no adjustments on the Ipad2 garageband app for latency. I just bought an IO Dock by Alessis. I'm inputing my old Strat and need to stop that delay-- . No active electronics on guitar- straight in to IO dock.

    BTW, I just purchase a new DELL-- never again- do not own Mac computer

    Been recording for 30 years, stopped the last 10 and now back to have simple fun. I called Apple, no help, called Alessis, on hold too long. any ideas.

    Big Daddy:confused:
     

Share This Page