Garageband suddenly freezing up

Discussion in 'Mac Apps and Mac App Store' started by thechromedrug, Mar 26, 2009.

  1. thechromedrug macrumors newbie

    Joined:
    Jan 18, 2009
    #1
    I've been using GB for years, with M-Audio Firewire Solo. I record guitar and vocals. Never any major problems that I couldn't fix (mostly based on M-audio device not being recognized occasionally). Files are large, multi tracks. I don't lock tracks and have never had performance issues. I have 2.0 ghz iMac with 1.25 gigs of RAM. Not running Leopard, using 10.4.11.

    Today I launched GB, the song file opened, then the mouse froze. For a couple of moments. When it unfroze, I simply moved the mouse and GB gave me the spinning rainbow wheel which never goes away. I can force quit GB but it doesn't ever actually quit. I had to turn the power off to reboot. All other functions and apps work fine after reboot. After reboot I launched a different GB song file from an external drive (my backup), and the same thing happened. GB worked fine the last five years, and today it doesn't. Any ideas?
    I don't believe the song files are corrupt, I opened them in Logic and they appeared and played normally. Please don't ask me to use Logic instead of GB!;)
     
  2. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #2
    First thing I would try is to trash the Garageband .plist file.
     
  3. thechromedrug thread starter macrumors newbie

    Joined:
    Jan 18, 2009
    #3
    Yes I plan on trying that when I get home. What about zapping the PRAM?
     
  4. thechromedrug thread starter macrumors newbie

    Joined:
    Jan 18, 2009
    #4
    Fixed!!!

    I first zapped the PRAM upon startup, then trashed GB prefs, then restarted again.

    Worked fine after that.

    Thanks!
     

Share This Page