GarageBand - turning off built-in mic & speakers

Discussion in 'Mac Apps and Mac App Store' started by Skipster, Apr 13, 2008.

  1. Skipster macrumors newbie

    Joined:
    Apr 13, 2008
    #1
    When I connect my microphones and headphones in through my M-Audio interface I expect these should override the mic & speakers that are built into my MacBook Pro - but that's not happening. :confused:

    Instead:
    1) the M-Audio interface DOES NOT provide signal to my headphones as I record,
    2) the speaker/headphone jack on the computer DOES provide signal to my headphones,
    3) and the built-in speakers play as I record.

    Also:
    1) the M-Audio interface DOES show the clip and signal lights reacting to my pro microphones,
    2) however, the system records signal even if I turn the mic volume to zero on the M-Audio interface. This makes me think the built-in mic is also recording, or perhaps is the only thing recording.

    Lastly, when I attempt to overdub on a new track, sound from the built-in speakers can be heard, which again is picked up as I record and presenting me with two monitoring signals that are out of sync - the speakers and the headphones.

    Sorry for the lengthy message. Any suggestions?

    Thx.
     
  2. platypus63 macrumors regular

    Joined:
    Feb 28, 2006
    Location:
    Zanzibar Land
    #2
    Have you gone to
    Garageband > Preferences > Audio/MIDI tab and select the audio output/input as the M-Audio? Once you do that, it will output garageband sounds (not system sounds) through the M-Audio. To output system sounds you would need to change that setting in the system preferences, although I would not recommend that, in case you're on iChat, its annoying to hear the IM sounds through the headphones while recording.

    Once the input/output in GB is set to M-Audio, you can select the Input source for the track you will record from the right side of the screen. And make sure you have the latest drivers if on Leopard. My M-audio firewire solo was acting up before I upgraded the drivers.

    Hope this helps
     
  3. Skipster thread starter macrumors newbie

    Joined:
    Apr 13, 2008
    #3
    Thanks for the reply - better, but no joy yet

    .
     
  4. Skipster thread starter macrumors newbie

    Joined:
    Apr 13, 2008
    #4
    Thanks for the reply - better, but no joy yet

    Thanks much. Your feedback helped me narrow the problem statement. That's a good thing. :)

    Current status:
    1. The Audio Input & Output in GB Preferences is now set for the M-Audio device, so that's good.
    2. Signal is getting to the track. I see the volume bar moving in the GB Track Mixer. I know the signal is from my "pro" mic because the lights move even when I lightly scratch on the mic, so that's good.
    3. I can hear playback on my headphones when plugged into the M-Audio device. But I cannot hear input signal in my headphones.
    4. I no longer hear sound on the laptop speakers!!!

    So the remaining problem seems to be that Input signal is either not getting to M-Audio device, or the M-Audio device is receiving Input signal, but not passing it to my headphones.

    As I understand all this, by all rights I should be hearing this input signal. Any thoughts?

    Thanks again!
     
  5. platypus63 macrumors regular

    Joined:
    Feb 28, 2006
    Location:
    Zanzibar Land
    #5
    Can you hear a playback of what was recorded on the headphones?
    Make sure "Monitor" is set to "On" on the track info panel on the right. (Just under the input source selection). That should give you live monitoring on what you're playing. Although if you have the m-audio firewire solo like i used to have, you'll probably get an annoying delay between what you play and hear.

    Anyway, let me know what you cant hear, playback or live monitoring... and I'll fool around w/ my box and GB and see what I can do for you.
     

Share This Page