GarageBand won't start...keeps on initializing..

Discussion in 'Mac Apps and Mac App Store' started by tobiasrieper, Jan 27, 2009.

  1. tobiasrieper macrumors newbie

    Jan 27, 2009
    Dear all,

    I tried to open GarageBand this afternoon for the first time (after using this new imac for almost half a year) today and it couldn't start.

    The 'Initializing..' window ran continuously for a long time (more than 2 mins) with no progress. I force-quitted and try loading it again several times and it didn't work.

    Here's the error message i got when I launched GarageBand from the terminal:

    2009-01-26 21:22:41.514 GarageBand7875:10b Invalid IFPkgRelocatedPath found in /Library/Receipts/GarageBandFactoryContent.pkg/Contents/Info.plist
    2009-01-26 21:22:41.515 GarageBand7875:10b Invalid IFPkgFlagDefaultLocation found in /Library/Receipts/GarageBandFactoryContent.pkg/Contents/Info.plist
    /Applications/ fork: Resource temporarily unavailable
    /Applications/ fork: Resource temporarily unavailable
    /Applications/ fork: Resource temporarily unavailable
    /Applications/ fork: Resource temporarily unavailable
    /Applications/ fork: Resource temporarily unavailable

    Please help~

    many thanks....
  2. JediMeister macrumors 68040

    Oct 9, 2008
    Create another user account on the computer, try to launch Garageband. If it hangs on initialization there you should check in Macintosh HD/Library/QuickTime. If there is anything in there other than the AppleIntermediateCodec or the AppleMPEG2Codec, drag out to the desktop, restart computer, try relaunching Garageband. If this doesn't fix it, try reinstalling Garageband from the Install Bundled Software Only shortcut on your software restore discs that came with the computer. If it launches successfully on the other user, you have some plist files to trash from home/library/preferences and the whole caches folder from home/library/caches.
  3. tobiasrieper thread starter macrumors newbie

    Jan 27, 2009
    thz for the reply~~~

    I finally found the real source of error~~:mad:

    it's an application called 'NTFS for Mac OSX' which I've been using quite a while for writing in the NTFS harddisk~ !

  4. jpbluzharp macrumors newbie

    Jan 5, 2010
    GarageBand won't open

    Just spent ten hours fixing the GarageBand problem... Now it will open! I was instructed by Apple to open my hard drive, open library, open application support file... I removed all Melodyne re wireDevice MelodyneE...
    then went down the list in library and found one MelodyneE.. vice.plugin and removed that.. threw all in the trash and GarageBand started right up. Thanks Apple
  5. BHRIV macrumors newbie

    Aug 10, 2010
    GarageBand not starting - won't initialize

    I had the same issued - thanks for posting the solution.

    I had just installed a new Mbox2, and a bunch of plugins. It seems the issue is with rewire applications.

    Go Library>Applications Support>
    Create a new folder "Temporarily Moved Folders"

    Put any Rewire folders (Propellerhead Software was my problem), into your new folder and Open GB.

    When you are done with GB, simply replace the "Temp moved Folders" back into App Support folder, and you'll be back where you started - with access to these plugins, while you are not using GB
  6. blizzardguy macrumors newbie

    Oct 30, 2010
    Thank You

    Thanks for this. I haven't used Garage Band for three years because I could never find the problem. I've tried so many different things including phoning Apple tech support and finally just gave up. When I installed iLife 11 I thought I would look into it one more time and found this post. The Propellerhead Software was the problem. Remove the folder and Garage Band starts.
  7. mac_wise macrumors newbie


    Apr 5, 2017
    Sorry to bump this 7 years later, but I have this problem but only when I open one particular file. Garageband works find for every other project I have but when I open this one file it stays stuck on the initializing blue loading bar. I followed the ReWire advice, moving it to another folder, but the project still doesn't open. Would anyone have solution to this? Let me know. Thanks.

    P.S. The weird thing is, after the project wouldn't open for a while, it randomly DID open one day. But ever since it's refused to. Permissions looked accurate and I don't think the file is corrupted.
  8. HarryVSS macrumors newbie


    Jan 9, 2018
    Maastricht Netherlands
    --- Post Merged, Jan 9, 2018 ---
    I had the same. After some trial and error (2 hours) I managed to open GB preferences, went to "audio midi" and clicked the in- and output buttons - I made no changes but initializing started again - then, when I closed GB (I did not work in the project, just closed it again after the re-initialzing) I was prompted to save the changes - which I did. I restarted my Macbook and opened GB again - this time all went normal.

    I have to say the system has always been hard when you want to use any other devices than the built in in- and output. I use Lexicon Alpha for a line in and it took me a lot of trouble to get it recognized - after which the initializing problem presented itself seemingly out of the blue. It almost drove me up the walls. But it works! It's a fine USB interface for almost no money.

    I hope this may help you - it would appear sometimes GB functions needs to be "reset" i.o. to work normally again.
    Other than that I have to say I love GB.

    And last but not least: "Have you tried turning it off and on again?"
    That may work! Cheers.

Share This Page