Gatekeeper disabled and still won't open my app

Discussion in 'OS X Mountain Lion (10.8)' started by wirtloto, Aug 22, 2012.

  1. wirtloto macrumors newbie

    Joined:
    Aug 22, 2012
    #1
    Hope someone can help me with this. I downloaded blender (a free 3d software compatible with 10.8) I disabled gatekeepr switching to allow application downloaded from anywhere and still doesn't open the app, I tried the right-click open the control+open nothing. Same situation with a demo version for video plugin for final cut and motion and same result. I try to open same software with a mac mini (os 10.6.8) no problem at all.

    Please please can anyone help me with this? Thanks in advance!
     
  2. Platskies macrumors member

    Joined:
    Jul 24, 2012
    Location:
    NSW, Australia
    #2
    No idea if this'll work, but from this page's examples, try this in Terminal:
    Code:
    spctl --assess /path/to/appBundle.app
    (if you don't know the path to the app, you can drag the application from the Finder into the Terminal window and its path will get "pasted" in)

    Trying on one of my downloaded apps, if you get a message saying it got rejected, try:
    Code:
    sudo spctl --add /path/to/appBundle.app
    (adds the app to an "allowed" list)

    You can also completely disable Gatekeeper - though I think it seems to have the same effect as clicking "Everywhere" in the Security preferences:
    Code:
    sudo spctl --master-disable
    Hope it helps :)
     

Share This Page