Gatekepper prevents installation of Adobe CS 5.5

Ankaa

macrumors 6502a
Original poster
Jul 27, 2008
682
507
Hi,

so, I got a new Mac (with Sierra, obviously) and just wanted to reinstall all my software. Just, I can't.

I own the Adobe Creative Suite 5.5 and just downloaded the dmg from their website. However, when I run the dmg and then want to run the installer, I encounter the following error:


"“Install” can’t be opened. You should eject the disk image."

And when I click on the little question mark get the following information:


"The app’s authorization has been revoked

There may be a problem with this app. Although the app was signed by an identified developer, the certificate for the app has been revoked, and it cannot be opened.

Check with the Mac App Store or the software developer to see whether there is an updated version of this app."

So, the open to open/install "any" software has been removed from the security settings. You can get them back, with a terminal command, but it didn't help. I'm still getting the same error.

So, you're telling me I can't install (older) software anymore just because Apple decides so? Seriously?!??!o_O

Is there any way? I've already tried what I found googling and worked for others (like the mentioned terminal command), but nothing helped, so far. I really need that software... (and no, I'm not going to buy the Creative Cloud stuff, I legally OWN the CS 5.5 and it's working perfectly on my other Mac which came with El Capitan and which I upgraded to sierra a few weeks back)

Any help VERY much appreciated.
 

KALLT

macrumors 603
Sep 23, 2008
5,133
3,181
Can you try these two commands (separately)? You can drag the installer executable into the window to resolve the path.
Code:
spctl --assess -vvvv /Path/To/Application.app
codesign -vvvv /Path/To/Application.app

I am interested in the output, to see whether there are some clues.
 

Partron22

macrumors 68030
Apr 13, 2011
2,573
760
Yes
Have you de-registered your older copies through Adobe?
There's an upper limit, I think 5 copies.
I've been running Photoshop since 1.0, and passed the limit a few times.
A quick call to Adobe was all it took to get things working again.
PS 5.5 is working for me just fine under Sierra.
 

julianabr

macrumors newbie
Aug 6, 2012
15
0
Can you try these two commands (separately)? You can drag the installer executable into the window to resolve the path.
Code:
spctl --assess -vvvv /Path/To/Application.app
codesign -vvvv /Path/To/Application.app

I am interested in the output, to see whether there are some clues.
This is what i got:


User$ spctl --assess -vvvv /Volumes/Adobe\ Photoshop\ CS5/Adobe\ Photoshop\ CS5/Install.app

/Volumes/Adobe Photoshop CS5/Adobe Photoshop CS5/Install.app: CSSMERR_TP_CERT_REVOKED

User$ codesign -vvvv /Volumes/Adobe\ Photoshop\ CS5/Adobe\ Photoshop\ CS5/Install.app

/Volumes/Adobe Photoshop CS5/Adobe Photoshop CS5/Install.app: CSSMERR_TP_CERT_REVOKED

In architecture: i386

Any thoughts on how to change that flag?

I've tried getting the "anywhere" button back, but it does not seem to help this particular error. I'm trying to install Photoshop CS5
[doublepost=1492786126][/doublepost]I FOUND A SOLUTION!!!! Yay, me. :)

I actually kept on searching and FINALLY came up with a fix on this forum:
Maxprog Forum • View topic - iCash 7.5.9 release

Here's what user ewin said:

Hi,
I have managed to fix the issue using the command below within the Terminal App:

sudo xattr -r -d com.apple.quarantine /Applications/iCash/

The issue appears to be that the Gatekeeper system is quarantining the app which stops the system from running it. The above command removes the quarantine status and allows the app to run.
Not sure why Gatekeeper thinks it needs to quarantine the app but at least I have a fix.

Regards​

So this is what to do:
  1. Copy the CS5 installer folder to your drive
  2. Open terminal and enter sudo xattr -r -d com.apple.quarantine (make sure you leave a space at the end)
  3. Drag the install file to your terminal window (it will fill in path name, etc.), and hit ENTER
  4. logout and close the terminal window
Doing that seemed to remove the "quarantine" and then i was able to double-click on the installer back in good old sierra and it ran.

This was actually not a New Operating Sys/Old App issue, but an issue with overly restrictive security measures that do not enable an override in an easy way, as did the previous version of the OS. I think it is a mistake to limit advanced users on what they can and cannot install. If I override something and it messes my machine up, well then that's on me. But it IS my machine and if I want to install something, I should be able to. If apple creates a "walled garden" system where I have to jailbreak it like an iphone, I will seriously think about going back to PC. As much as I detest windows, it allows the fact that it is my machine to do with what i will.

Anyway, hope this helps other frustrated users....
 

KALLT

macrumors 603
Sep 23, 2008
5,133
3,181
This is what i got:


User$ spctl --assess -vvvv /Volumes/Adobe\ Photoshop\ CS5/Adobe\ Photoshop\ CS5/Install.app

/Volumes/Adobe Photoshop CS5/Adobe Photoshop CS5/Install.app: CSSMERR_TP_CERT_REVOKED

User$ codesign -vvvv /Volumes/Adobe\ Photoshop\ CS5/Adobe\ Photoshop\ CS5/Install.app

/Volumes/Adobe Photoshop CS5/Adobe Photoshop CS5/Install.app: CSSMERR_TP_CERT_REVOKED

In architecture: i386

Any thoughts on how to change that flag?

I've tried getting the "anywhere" button back, but it does not seem to help this particular error. I'm trying to install Photoshop CS5
The developer certificate seems to have been revoked. You should contact the developer and download a new copy, if available.

So this is what to do:
  1. Copy the CS5 installer folder to your drive
  2. Open terminal and enter sudo xattr -r -d com.apple.quarantine (make sure you leave a space at the end)
  3. Drag the install file to your terminal window (it will fill in path name, etc.), and hit ENTER
  4. logout and close the terminal window
Doing that seemed to remove the "quarantine" and then i was able to double-click on the installer back in good old sierra and it ran.

This was actually not a New Operating Sys/Old App issue, but an issue with overly restrictive security measures that do not enable an override in an easy way, as did the previous version of the OS. I think it is a mistake to limit advanced users on what they can and cannot install. If I override something and it messes my machine up, well then that's on me. But it IS my machine and if I want to install something, I should be able to. If apple creates a "walled garden" system where I have to jailbreak it like an iphone, I will seriously think about going back to PC. As much as I detest windows, it allows the fact that it is my machine to do with what i will.

Anyway, hope this helps other frustrated users....
I highly recommend to not do this lightly. Ignoring code-signing errors can easily result in malware. This has nothing to do with being an ‘advanced user’ or not, it is a legitimate precaution and the OS tells you that something is wrong. If this app were not code-signed at all, ignoring Gatekeeper would have been easy.
 
Last edited:

Hipstix

macrumors newbie
May 28, 2017
1
0
So I had the same problem, before I found this forum. I had just re-installed sierra for other reasons wiping out 5.5. I still have the disks, but I could not find 5.5 install disk from last time I installed, I have the original disk (somewhere). So I was very frustrated because I just had 5.5 on there hours before I re-installed sierra, and now the downloaded copy won't work. After ripping my hair out, I found the original install disk behind my nightstand (in the protective sleeve) . It installed perfectly like before. And I installed on two fresh copy of sierra based Macs. It's the downloaded copy that is giving the problem. If you have original 5.5 install DVD , it will install with no problem. You do need to have a legacy copy of java too, but the original disk installs as if you had snow leopard on the machine.
 

julianabr

macrumors newbie
Aug 6, 2012
15
0
The developer certificate seems to have been revoked. You should contact the developer and download a new copy, if available.

I highly recommend to not do this lightly. Ignoring code-signing errors can easily result in malware. This has nothing to do with being an ‘advanced user’ or not, it is a legitimate precaution and the OS tells you that something is wrong. If this app were not code-signed at all, ignoring Gatekeeper would have been easy.
Yeah, I agree, but I don't do this kind of thing lightly. Part of the problem is that Adobe is longer supporting this version of photoshop, as it is several years and a few updates old. They have moved their business model from a 'purchase once and own it' license to a cloud-based monthly model. This version of Photoshop is the last one that you could still own outright. For users who need to use it daily and/or even weekly, the fee structure is not outrageous, but for users like me, it just doesn't make sense. I need the advanced features of Photoshop, but I only need it a few times a year.

The file in question was downloaded directly from adobe, a company I trust. The gatekeeper only denied me the ability to easily approve the software on macs that had not upgraded to sierra, so I knew that this was a function of some new level of security. I was not interested in downgrading that mac in order to install this software.

Based on all of that, I decided that it was my risk to take. I was not pleased that the new OS took away my ability to look at the variables and make a decision.


In answer to HipStix above: My original licensed copy was a download that got lost somewhere in the transfer to and from various computers and network drives over the years. No disk. :) Adobe very conveniently provides these installs of old versions but will not support them with their customer support staff. Which is understandable for software that is several years old.
 

flowrider

macrumors 603
Nov 23, 2012
6,114
2,321
This version of Photoshop is the last one that you could still own outright.
Actually CS6 is the last version you can own and not rent. PS CS6 was last updated to V 13.0.6 in Nov 2013. Bridge CC2017 works with PS CS6.

Lou
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.