Geektool and Mavericks

Discussion in 'OS X Mavericks (10.9)' started by Communicator, Oct 23, 2013.

  1. Communicator macrumors newbie

    Joined:
    Mar 12, 2013
    #1
    Hoping someone can advise or help.

    I updated to OS X Mavericks today, and when it started up for the first time on the MacBook Pro Retina, it kept throwing up a window listing all apps and above it the question 'where is Spotify.app?', then the option to choose or cancel.

    However, pressing Cancel only did so for a few seconds and the window appeared again and again.

    I discovered that when I stopped Geektool running, the problem ceased and Mac operation returned to normal.

    I've never had Spotify installed or used it, as far as I know!

    Is there a problem with Geektool or a script?

    I miss using Geektool, so if anyone can explain what's happening and offer a solution, I'd be grateful.

    Thanks.
     
  2. beks6 macrumors newbie

    Joined:
    Feb 6, 2012
    Location:
    Vienna, Austria
    #2
    i think it's a problem with a script.

    i updated also yesterday to Mavericks and i don't have such an issue.

    the only issue i noticed is that this script for a calendar is not working

    Code:
    #!/usr/bin/env ruby
    #
    # Author: Robert Jorgenson
    # Author email: rjorgenson@gmail.com
    require 'Date'
    ABBR_DAYNAMES = {0, 'So', 1, 'Mo', 2, 'Di', 3, 'Mi', 4, 'Do', 5, 'Fr', 6, 'Sa'}
    
    def days_in_month(year, month)
      return (Date.new(year, 12, 31) << (12 - month)).day
    end
    
    def day_in_month(year, month, day)
      return Date.new(year, month, day).wday
    end
    
    def build_day_array(year, month)
      day_array = Array.new
      for d in (1..days_in_month(year, month))
        day_array[d] = ABBR_DAYNAMES[day_in_month(year, month, d)]
      end
      day_array.shift
      return day_array * "     "
    end
    
    def build_separator(year, month)
      color = "\e[30m" #black
      color = "\e[37m" #uncomment for white
      separator_string = "███" # change this to change separator, best if 2 characters wide
      close = "\e[0m" # don't change this
      separator = Array.new
      for d in (1..days_in_month(year, month))
        if year == Time.now.year && month == Time.now.month && d == Time.now.day then
          separator[d] = "#{color}#{separator_string}#{close}"
        else
          separator[d] = "#{separator_string}"
        end
      end
      separator.shift
      return separator * "████"
    end
    
    def build_date_array(year, month)
      date_array = Array.new
      for d in (1..days_in_month(year, month))
        date_array[d] = d
      end
      date_array.shift
      date_array.each do |d|
        if d < 10 then
          date_array[(d-1)] = "0#{d}"
        end
      end
      return date_array * "     "
    end
    
    year = Time.now.year
    month = Time.now.month
    
    puts build_day_array(year, month)
    puts build_separator(year, month)
    puts build_date_array(year, month)
     
  3. Communicator thread starter macrumors newbie

    Joined:
    Mar 12, 2013
    #3
    Thanks for the reply, Beks6.

    It is indeed a script problem I had.

    All my scripts run fine, except the one that displays the new iTunes information, that is, the song playing and the album art work.

    Each time I add that to the running scripts, my problem of the flashing window appeared instantly.

    I just stopped that Geeklet and all the others run fine.
    I can live without the iTunes info!

    Thanks again for your reply.
     
  4. Kschulze12 macrumors newbie

    Joined:
    Nov 3, 2013
    #4
    Problems with GeekTool on Mavericks

    So I just decided to try using GeekTool, but whenever I try to drag a Shell onto my desktop, it just goes right back into GeekTool without sticking. I've tried uninstalling and reinstalling Geektool, but it hasn't worked. I don't know what else to do, nothing is working. Also, I am using OS X Mavericks, the newest operating system, if that makes a difference. Any advice?

    -Kyle
     
  5. alternapop macrumors newbie

    Joined:
    Sep 9, 2003
    #5
    I had the same problem and was looking for a solution. I found this post hoping to find a solution. I ended up quitting GeekTool and reopening and it worked the second time.
     

Share This Page