Geektool GeekTool Problem

Discussion in 'UI Customization' started by PenriMainwaring, Jul 27, 2011.

  1. PenriMainwaring macrumors newbie

    Jul 27, 2011
    Hey guys,

    1st time post, just downloaded GeekTool and looked up some tutorials...but I'm having one big problem.

    When opening GeekTool, I am welcomed to a blank Properties box with just "Geeklet Settings". Many tutorials have told me to drag either "file" "Images or "Shel" onto the desktop. I do this and nothing happens. The little black box that appears when you click and drag bounces back up to the GeekTool 3 preference box.

    I'm un-installed and re-installed the program 3 different ways.

    If I'm being a complete idiot or noob I don't mind, I just would like to start using the program.

    Thank you for your help
  2. jbjones85 macrumors member

    Feb 6, 2011
    What OS are you using?

  3. askervest macrumors newbie

    Aug 2, 2011
    Same problem


    I have the same problem using geektool 3.0

    I am using OS X Lion...

    Cant get the geeklets to stick to the desktop, they just bounce back..
  4. xtacocorex macrumors regular

    Oct 23, 2010
  5. lolol Filip macrumors newbie

    Jan 19, 2011
    I have the exact same problem, except I'm on Snow Leopard and not Lion. Any help?
  6. laxman101 macrumors regular

    May 6, 2011
  7. Gofre macrumors regular

    Feb 7, 2011

    Try that. It's working file with Shells, yet to try it with anything else yet.
  8. laxman101 macrumors regular

    May 6, 2011
    Found that link a little while ago, thanks anyway!
  9. schiedi macrumors newbie

    Aug 25, 2011
    No preference pane on any version


    I tried out this (, but still the same.
    Is it possible that there are some old files remaining on my disk?

    How can I completely remove any old stuff? Amnesia doesn't, I fear.

    Please help be get it running again!

    I see only this:


  10. Jenni8 macrumors member

    Apr 27, 2011
    Ok I can relate if it's the same weirdness I was having. If you are thinking to just drag an app or picture into the app or just drag the shell file or such to the desktop their is a little more to it. I found out their is a reason it's called Geektool. Hehe. Well I sure felt like a nOOb when I figured out how to use it. You can either write you own scripts using some easy lists I've found or even easier if you have no desire how to write one from scratch, then download some pre made geeklets from this website. They are easy to modify.

    So far it seems to be the only site with a good selection of user made geeklets I can find. Nothing else seems to compare. Unless someone is aware of another useful selection.

    But once I started reading the guides of how the coding works, it seems to be pretty simple when it comes right down to it, at least when it comes to the simple scripts.

    It seems the tool is pretty limited as to what kind of information you are pulling from your computer, but I haven't ventured into how it pulls info from the internet. Just using the pre made ones.

    My favorite script so far I've downloaded was for the gmail ticker. I could never seem to find a free one that works as it should. I was using the growl but the mail extension is now outdated and no longer works on lion. And that never seemed to work right for me on SL anyway. So now I have a subtle ticker in the corner so I always know I have email without having to open a client or website. :)

    Having all the subtle info on the desktop handy with Geektool is something I love so far. I only wish that you can dedicate Geektool to only run on selected desktops instead of them all. Unless I'm missing something here.

    I'm no expert in anyway and am new to the sweet app. I just thought I'd share my own nOOb experience in case it just might help someone like me. :D

    To find a guide that works for you just google it. It should be the first step to all questions. It helps reduce redundancy in forums such as this one. Most of the time when I ask questions through google it will lead me here. It's more efficient that MacRumors own search IMHO. I just always be aware of the age of such questions, so some answers can be outdated, especially with Lion being so new still and all.

    Have fun with the Geeklets!
  11. schiedi macrumors newbie

    Aug 25, 2011
  12. zdlyons macrumors member

    Sep 30, 2010
    Shell order

    I have a question about the shells too... is there a way to re order them if you want to put a new one behind others? I can't figure it out and couldn't find it searching Google. Thanks guys.

    Never mind. evidentially some things in GeekTool are simple and can be solved with actions like right clicking.
  13. Rzah macrumors newbie

    Dec 14, 2011

    Close the Prefpane if its open.
    Open your Library folder (hold down alt whilst clicking on the Finder's "Go" menu), navigate to Preferences, search for "geek", trash the geektool .lockfiles. I had three of them, worked fine after that.
  14. wonderspark macrumors 68040


    Feb 4, 2010
    Would you be willing to share the Gmail geeklet / script that doesn't use growl? That is the one thing missing from my desktop. :)
  15. tktaylor1 macrumors 6502a


    Feb 16, 2010
    Nashville, TN
    I haven't read all of the replies but I had this problem. Uninstall Geektool, go to the App Store and reinstall it. It should work fine.
  16. NetoBullet macrumors newbie


    Apr 3, 2013
    GeekTool Helper

    The GeekTool Helper was the culprit here.

    in the Finder menu bar, look for a small icon similar to the Terminal icon.
    it could be another instance of GeekTool Helper from a previous instalation.

    Just quit it and GeekTool should work.

    It's a good idea remove any GeekTool Start Up item on System Preferences -> Users & Groups -> Login itens

Share This Page