Resolved Geektools and glets on Lion

Discussion in 'macOS' started by black7205, Aug 31, 2011.

  1. black7205, Aug 31, 2011
    Last edited: Aug 31, 2011

    black7205 macrumors newbie

    Joined:
    Aug 31, 2011
    #1
    Hi,

    I just installed Geektools from the Appstore on to my MBA, running Lion.
    And I can place the build in glets on to the desktop and everything works just fine.
    However, I downloaded a bunch of glets and start them with GeekToolsHelper, but nothing happens and they don't show up in GeekTools

    The glet files are associated with the GeekToolsHelper application and I see that Finder is loosing focus after I double clicked on a glet file. But nothing else happens, except that I can see that a GeekToolHelper process has been launched.

    Any ideas how to attack this problem?

    EDIT:
    Just found this in the system.log, no matter which glet I double click on.

    GeekTool Helper[1003]: An exception was thrown during execution of an NSScriptCommand...
    GeekTool Helper[1003]: *** -[__NSArrayM insertObject:atIndex:]: object cannot be nil



    Thanks,
    Black
     
  2. Ctt713 macrumors member

    Joined:
    Jul 6, 2009
    #2
    I think I am actually having a very similar if not the same issue. I have downloaded geektool but every time i try and run a .glet it says Geektool cant open that file type and is unrecognized. I tried to open them int textedit and copy the code with no success. Tutorials aren't helping much either.
     
  3. black7205 thread starter macrumors newbie

    Joined:
    Aug 31, 2011
    #3
    Found this in another forum:
    glet files need to be set to open with "GeekTool Helper" instead of GeekTool. This should be automatic if you just double-click them. If that doesn't work:

    Make sure you have updated to the latest GeekTool (via Mac App Store or here).
    Right-click on a .glet file and choose "Get Info".
    Under "Open With" in the Get Info window, choose "Other".
    Press Command-Shift-G on your keyboard.
    A "Go to folder" box should appear, copy/paste in:
    /Applications/GeekTool.app/Contents/PlugIns/GeekTool.prefPane/Contents/Resources/
    GeekTool Helper should be in that folder. Click it.
    Also click the "Change All" button in the Get Info window.

    ----------

    And I also found the solution to my problem.

    The glet files I found here:
    http://www.macosxtips.co.uk/geeklets/collections/space-desktop-theme/
    Where actually not really glet files, but commands to be used in glets.
    Technically they are not XML files (a specific format that GeekTool Helper would understand), but instead these are just command lines that can be used to configure your own geeklets.

    Using geeklets form another theme on the same page works just fine.

    So checking the content and not only the file extension solved my problem.
     

Share This Page