General error with redns0w

guido.coza

macrumors member
Original poster
Jan 12, 2011
94
0
South Africa
Hi guys
at my wits end
Try now for days to get a jailbreak on my 3gs without luck.
I run redsn0w_mac_0.9.10b6 to jailbreak my phone 3gs runing on 5.1? (updated by iTunes in restore) I try to create custom ipsw NO_BB_iPhone2,1_5.1_9B176_Restore.ipsw but than i get "Custom IPSW creation failed General error."
Where is the fault??:confused::confused::confused:
 

guido.coza

macrumors member
Original poster
Jan 12, 2011
94
0
South Africa
You should be using the newest version of Redsn0w for MacOS

redsn0w 0.9.10b6b
I did use10b6 the isigned ipsw is NO_BB_iPhone2,1_5.1_9b176_Retsore.ipsw.
It does not except this ipsw
I followed the www.iclarified.com/entry/index.php?enid=20512 to the letter
still :mad::mad: It will stuck at general error.
I can"t activate the phone either. If i use wifi it says could not activate if i use iTunes it asks for sim card( dont have original sim!!

HEEEEEEEELP:confused::confused::confused:
O by the way thanks for all the help so far in the other threads. If you should have a solution please point me to a step by step place I'm only user, blond and male (-:
Again txs guys
 
Last edited:

guido.coza

macrumors member
Original poster
Jan 12, 2011
94
0
South Africa
Redsnow will never accept or recognize a "No_BB" custom firmware file.
You need to point it to the stock .ipsw file to do go on with the rest. That's why you're getting an error.
Hi Applejuiced
I found in most threads that i must NOT use the standart apple firmware but will try to do so.
If u go to the iclarified page it says under step 8
"CUSTOM IPSW CREATED
.......
BE VERY CARFULL TO NOT ACCIDENTLY USE THE STOCK IPSW!
use only NO_BB......
under step 18 it says select IPSW from PWNAGE folder
I seem not to be able to create that folder
I downloded the file but cant create the folder so when I click restore I GUESS? it restores with original apple software. It also does not allow me to choose anything manually. (went to libraray and put" NO_BB..' file into the iphone software update folder????
So i did the whole thing again and I'm back at the beginning.
I still have the apple logo and can't activate the phone.
This is really frustrating for me, pls dont give up on me and be patient (-:
 
Last edited:

guido.coza

macrumors member
Original poster
Jan 12, 2011
94
0
South Africa
as i said i'm blond. Did not hold down option key at first!
Did it again, could select NO_BB_.. file
File was loaded but still the same result if i Try to jailbreak the phone afterwards it tells me no identifying data fetched!!!!
What now??????:mad::confused:
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,650
6,404
At the iPhone hacks section.
as i said i'm blond. Did not hold down option key at first!
Did it again, could select NO_BB_.. file
File was loaded but still the same result if i Try to jailbreak the phone afterwards it tells me no identifying data fetched!!!!
What now??????:mad::confused:
Did you put the iPhone in pwned dfu before you try to restore?
When you use redsnow you point redsnow to the official firmware. Not the no-bb custom you created.
When you restore with iTunes you select with alt the custom no bb ipsw and restore to that.
I don't know if you're getting it all. One wrong or forgotten step and it won't work.
 

guido.coza

macrumors member
Original poster
Jan 12, 2011
94
0
South Africa
Did you put the iPhone in pwned dfu before you try to restore?
When you use redsnow you point redsnow to the official firmware. Not the no-bb custom you created.
When you restore with iTunes you select with alt the custom no bb ipsw and restore to that.
I don't know if you're getting it all. One wrong or forgotten step and it won't work.
Hi Again
Yes these r the steps i took. I at ones forgot to select with "alt" but than did the whole prosses over.