Generic Folder Icon problem in Mavericks

Discussion in 'Mac Basics and Help' started by corlioghost, May 20, 2014.

  1. corlioghost macrumors newbie

    Joined:
    May 20, 2014
    #1
    I recently changed a whole wack of icons in my dock with a more flat design, and I also wanted to change the generic folder icon to match that theme, so I went into /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources and changed the GenericFolderIcon.icns.

    When I restarted, all the folders reverted to a blank document icon, but the file was still in its proper folder. I also tried reversing it back to the original icon, but no luck. How do I get the system to recognize the icon?
     
  2. anonthymous macrumors newbie

    anonthymous

    Joined:
    Sep 28, 2014
    #2
    This seems long overdue but are do you still have problems recustomizing your genericfoldericons? I experienced something very similar to what you described. Here are some of my suggestions (quick fixes):

    1. Download candybar - its a utility that does the same thing with changing icons and has a nice GUI.

    Once downloaded, change the genericfoldericons by reapplying your custom icon. Thereafter, it prompts you to log out to preserve the changes. Log out, restart your computer and the genericfolder should be updated to reflect your custom icon.

    Although this worked for me and if you eery about candybar, you could simply try logging out, logging on, then restarting your os.

    2. Try Relaunching the Finder. Holding the "options key" right click the Finder icon on Dock. A popup should appear. Click "Relaunch" and afterwards, restart your OS.

    3. I have a feeling it has something to do with .DStore or MetaData files that were created in the event you copied/pasted your icon. I confirmed this was not the case with my mac as I navigated via terminal and couldn't find if after executing the terminal command: ls -laxo in the directory /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources. Check if you have it and if you do, remove such files but I do not recommend this as (if you don't have experience with bash/terminal) can permanently delete system files.
     

Share This Page