Genius Bar Formats and reinstalls desktop software instead...

Discussion in 'MacBook Air' started by ooo, Mar 2, 2009.

  1. ooo macrumors 6502

    Joined:
    Nov 23, 2007
    #1
    ... for starters I'm not exactly happy with this. I had a broken fan problem and i brought in my air to get it fixed and I told them to reformat it since I don't have any means to format it at home. Well they fix my fan problem, a tiny tab or ribbon is sticking out of the case though, no problem with that. I just used something and pushed it back in. Now the big problem is they seemed to install a desktop leopard on my air. I can not change the settings of my trackpad (meaning no right click, no tap to click, mouse gestures) and none of the function keys work on my air. The keyboard illumination doesn't work either. I even have a little icon to eject a cd from my air :).

    Is there anything I can do to get my preferences back as it took me five days to get my air back and I'm not really in the mood to wait another week for it.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Sounds like they imaged a somewhat incompatible build of OS X on the machine. A lot of those features are machine specific right now too.
     
  3. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #3
    If you took it back to the store and explained the issue they created, I'd be surprised if they didn't fix it right away.
     
  4. ooo thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #4
    Well I'm about an hour and a half away from the store at the moment and with the snow at 9 inches right now, it's not exactly a fun travel. I'm trying to see if installing the four finger mouse gesture thing would work. If not I'm going to give them a call and see if I can just drop down the computer tomorrow morning. The earliest genius bar slot is for Thursday at the moment.
     
  5. jaw04005 macrumors 601

    jaw04005

    Joined:
    Aug 19, 2003
    Location:
    AR
  6. ooo thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #6
    Ha, I fixed it myself. I used the four finger mouse gesture hack and sure enough it added a trackpad setting on my computer. The function keys work now, my keyboard illuminates and my trackpad works now.

    Yes, I do have the cds. However it is useless as I can't use it for the following reasons.

    1) No airport - required for a network install
    2) No usb ethernet plug - required for a network install
    3) No super drive - required for a usb install

    ^ Basically if you want to format your air, your out of luck unless you own one of those. I would get a super drive if it wasn't only macbook air compatible. That restriction just kills it for me.
     

Share This Page