Gesture = Crash!!!!

Discussion in 'Mac OS X Lion (10.7)' started by mwxiao, Jul 20, 2011.

  1. mwxiao macrumors regular

    Joined:
    Jul 5, 2007
    Location:
    CT
    #1
    How to file a bug?

    Let me know if you can reproduce this:

    1. Change gesture of magic mouse in preference to this:
    (1) swipe between pages: change to one or two fingers
    (2) switch between full-screen apps: uncheck.

    2. change gesture of trackpad in preference to this:
    (1) swipe between pages: with two fingers or three fingers.
    (2) swipe between full-screen apps: (should be automatically changed) four fingers.

    The reason I am changing these gestures is because this is the only way to get the back/forward gesture back in Finder or any browser.

    Now here comes the bug:
    Open iPhoto, click a photo, try to swipe your fingers on trackpad or magic mouse, with two or three fingers. And in a few seconds, you should see iPhoto crashes.

    Same bug applies to iWork or Chrome.

    If anyone can reproduce this bug, please tell me (and also let me know how to file a bug).

    On the second note, anyone have problem connecting your magic mouse after waking up? In SL, I open the lid and my mouse would be automatically connected. But in Lion, I have to manually connect every single time.
     
  2. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #2
    This crashing is incredibly frustrating in Chrome. For some reason I seem to always get a crash in Chrome when trying to swipe up or down with three fingers, no matter what trackpad settings I have. With BetterTouchTool enabled I seem to have the crash when I swipe either left or right with three fingers. I have not enabled any 3 finger gestures in BTT.
     
  3. justinfreid macrumors 6502

    justinfreid

    Joined:
    Nov 24, 2009
    Location:
    NEW Jersey / USA
    #3
    I can replicate the problem and it's really inconvenient. All current versions of Chrome, from Stable to Canary, exhibit this behavior. I hope a fix is forthcoming shortly, I rely heavily on that gesture.
     
  4. cavman88 macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    gesture=crash

    Hello,

    I have been having the same exact issue. I spent almost an HOUR AND A HALF on the phone with Apple yesterday as they seemed to be completely unaware of the issue. Ultimately, the tech helping me had me do a data capture to see the system logs when the crash occurs. They should be contacting me within 4-5 business days and hopefully a fix will be found soon. i'll update when I hear from them!
     
  5. Jelite macrumors 6502a

    Joined:
    Feb 16, 2008
    Location:
    UK
    #5
    I posted this in another thread, it may help.

     
  6. sketdansu macrumors member

    Joined:
    May 25, 2011
    #6
    finally someone who posts details rather than just whining, thanks and I will try to reproduce this and get back to you
     
  7. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #7
    It turns out that all my crashing issues were due to the remnants of MultiClutch on my system. I have long deleted the prefpane. After removing the MultiClutch Input Managers in " /Library/InputManagers", my crashing problems were fixed.

    I do not have this AirKeysInputManager on my system however it too is probably causing the same problems as the MultiClutch input managers. I do have BTT installed so that may not be causing the problem. It would be good to identify which application installs those input managers.

    EDIT:
    Apparently a SIMBL plugin was developed for MultiClutch to work in 64-bit and that utilises the AirKeysInputManager.
     
  8. rowdyreverb macrumors newbie

    Joined:
    Jul 18, 2010
    Location:
    Austin, TX
    #8
    This fixed my issue perfectly, thanks!
     
  9. Macfly77 macrumors newbie

    Joined:
    Sep 7, 2009
    #9
    That worked for me too. Thank you (I was already getting tired of using a regular USB mouse... there's really no going back once you use a Magic Mouse!)!
     
  10. cavman88 macrumors newbie

    Joined:
    Jul 21, 2011
    #10
    issues


    I don't think I ever downloaded multiclutch. Where should I search for it?
     
  11. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #11
    Just check "/Library/InputManagers". It is most likely in the main library but it could also be in your user library. This is located at the root of your main disk (usually Macintosh HD). If there is no InputManagers folder then it probably isn't there. You could try any SIMBL plugin folders. Just search your system for SIMBL and then see if there are any is an AirKeysInputManager.bundle somewhere in the plugin folder.
     
  12. kai920 macrumors member

    Joined:
    Jul 21, 2009
    #12
    aresinferno - your suggestion worked for me too, thanks! I am going back to Firefox & Chrome. ;)
     

Share This Page