Get access to change my read only files

Discussion in 'Mac Basics and Help' started by rogco, Nov 13, 2010.

  1. rogco macrumors newbie

    Joined:
    Nov 13, 2010
    #1
    Hi

    Somehow when I imported files from my PC to my Mac these files became read only.

    Is there a way to change their status so that I can edit them on my Mac? - 10.5.8

    Thanks
    Rogco
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Right-click on a file, Get Info, at the bottom of the window, change permissions under Sharing & Permissions.
     
  3. rogco thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #3
    Many thanks

    I had looked in that area but it was greyed out.

    After your post I looked again saw the padlock and realised it was locked.

    Simple but annoying problem solved.

    Thanks :)
     
  4. tonymce macrumors newbie

    Joined:
    Dec 14, 2010
    #4
    Read Only EHDD

    With my apologies for continuing this thread, I have a Maxtor One Touch 4 external HD. All files on this are read only and no more files can be added to the EHDD.

    On the "Get Info" screen under sharing and Permissions is the message "You can only read". There is, however, no padlock and no way I can see to unlock the drive. Can you help?
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    How is the drive formatted? Right-click and Get Info on the drive to check.
     
  6. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #6
    Most likely the drive is formatted as NTFS, which OSx can only read, not write unless you install extra software.
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    That's my thinking, but as is the case too many times with first-time posters, chances are high that tonymce will never post again, so we'll never know.
     
  8. padrino123, Jan 14, 2012
    Last edited by a moderator: Jan 14, 2012

    padrino123 macrumors newbie

    Joined:
    Jan 14, 2012
    #8
    Hey so I have the same problem. I originally formatted my hard drive when I had snow leopard and now that I have lion and it will only allow me to read only. I can read/copy whatever I want on it but I can't add anything to the hand drive. It is formatted NTFS. But I don't know where to go from here.

    Thanks guys. And I'll try not to be one of those first time posters and see this problem through, haha

    I've also tried this sequence in terminal, tells me its a read only file then the next line it tells me I can not change the permission type

    sudo chflags 0 /Volumes/My\ HD
    sudo chown 0:80 /Volumes/My\ HD
    sudo chmod 775 /Volumes/My\ HD
    sudo chmod -N /Volumes/My\ HD

    And then when I ran ls -go this is the info it gave me

    drwxr-xr-x 1 143360 Jan 13 23:03 Elements
    lrwxr-xr-x 1 1 Jan 13 08:14 Macintosh HD -> /
    drwxrwxrwx 0 0 Jan 14 11:03 MobileBackups
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    That's because you obviously had installed NTFS drivers on SL and you haven't done that yet on Lion.

    NTFS (Windows NT File System)
    • Read/Write NTFS from native Windows.
    • Read only NTFS from native Mac OS X
      [*]To Read/Write/Format NTFS from Mac OS X, here are some alternatives:
      • For Mac OS X 10.4 or later (32 or 64-bit), install Paragon (approx $20) (Best Choice for Lion)
      • For 32-bit Mac OS X, install NTFS-3G for Mac OS X (free) (does not work in 64-bit mode)
      • For 64-bit Snow Leopard, read this: MacFUSE for 64-bit Snow Leopard
      • Some have reported problems using Tuxera (approx $36).
      • Native NTFS support can be enabled in Snow Leopard and Lion, but is not advisable, due to instability.
    • AirPort Extreme (802.11n) and Time Capsule do not support NTFS
    • Maximum file size: 16 TB
    • Maximum volume size: 256TB
    • You can use this format if you routinely share a drive with multiple Windows systems.
     
  10. padrino123 macrumors newbie

    Joined:
    Jan 14, 2012
    #10
    Awesome. Thanks! Yeah previously I had MacFuse but it doesn't work anymore (got a new hard drive in my laptop) cause I need a 64 bit. So i downloaded the Tuxera and it worked. I'm able to move around freely now.

    Final question, I only have the 15 day trial so after that expires will I not be able to access the external hard drive anymore or can i permanently changed it through Tuxera?

    Thanks again
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    No, you'll need to buy it.
     

Share This Page