Get JAVA Cup symbol, but app will not work

Discussion in 'macOS' started by des325, Mar 22, 2009.

  1. des325 macrumors newbie

    Joined:
    Mar 22, 2009
    #1
    When running certain apps when logged in to my MAC (OS 10.5.6), I get the Java cup symbol (the one with arrows around it), but no app. When logged into the same mac as other users (my family), they run fine. Any ideas how to resolve?
     
  2. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #2
    Can you try running the application from terminal for both and see if you still get different results?

    I'm wondering if the accounts are setup with different JREs.
     
  3. des325 thread starter macrumors newbie

    Joined:
    Mar 22, 2009
    #3
    wish I actually knew what any of that meant. We have a basic iMAC (which we love), set up with separate accounts for my wife and another for my son. Going to a simple game app on the internet (e.g. http://lifewise.canoe.ca/Puzzles/addthemup.html) causes the problem when I am logged in, but not my wife.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    The problem is almost certainly your Java applet preferences not matching the version of Java the applet requires. To fix this, open Applications -> Utilities -> Java -> Java Preferences, find the Applet Java version preference, and change it to Java 5 or Java 6.
     
  5. des325 thread starter macrumors newbie

    Joined:
    Mar 22, 2009
    #5
    Thanks

    Thanks for your help. As it turns out, here is the nature of the problem. When I ran the system monitor and check Safari, it said that I was running a powerpc instead of Intel. I eventually did a "control-click" on the Safari application in Applications, selected "Get Info", and unchecked "open with rosetta". This solved the problem.
     

Share This Page