iPhone Get "LTE" back instead of "4G"

robertkarlsen

macrumors 6502
Original poster
Aug 13, 2011
259
45
Halmstad, Sweden
Couple of weeks ago i got a carrier update (Hutch Sweden) and after that, the sweet LTE data indicator was replaced with 4G. How can i bring back LTE? Hate 4G. Having a hard time to seperate it from 3G due to some issies with my sight!
 

Intell

macrumors P6
Jan 24, 2010
18,883
373
Inside
It's possible that the carrier bundle overrides 3G with 4G. Thus, never showing the 3G icon. Much like AT&T in the US.
 
Comment

bandofbrothers

macrumors 601
Oct 14, 2007
4,780
328
Uk
In the Uk we are stuck with the 4G icon too.

Would prefer Lte myself.

Probably a tweak somewhere !
 
Comment

hharzer

macrumors member
Jun 18, 2013
69
0
I looked up one of the carrier bundles I know that use 4G instead of LTE ( I hate this, too - don't know why :rolleyes: ).

There was a file called carrier.plist where you could set the indicator.

it's called DataIndicatorOverrideForLTE

Maybe you can try this, but I cannot use LTE with my contract at the moment.
 
Comment

robertkarlsen

macrumors 6502
Original poster
Aug 13, 2011
259
45
Halmstad, Sweden
Get "LTE" back instead of "4G"

I looked up one of the carrier bundles I know that use 4G instead of LTE ( I hate this, too - don't know why :rolleyes: ).



There was a file called carrier.plist where you could set the indicator.



it's called DataIndicatorOverrideForLTE



Maybe you can try this, but I cannot use LTE with my contract at the moment.

located where? :)

EDIT: Found it, didnt work!
 
Comment

Idefix

macrumors 6502a
Jul 10, 2012
523
72
Hint: try turning off wifi (briefly) and see if the LTE returns.

Works that way here...but since I keep wifi on all the time, not much use. As soon as I turn wifi back on, LTE disappears.
 
Comment

dasx

macrumors 65816
Jun 18, 2012
1,098
17
Barcelona
In Winterboard, at least with iOS 6, if you created the following folder under themes:

Code:
Bundles/com.apple.UIKit
And put inside files such as:

Code:
./ColorOnGrayShadow_DataType4G.png
./ColorOnGrayShadow_DataType4G@2x.png
./ColorOnGrayShadow_DataType4G_2only_.png
./ColorOnGrayShadow_DataType4G_2only_@2x.png
./WhiteOnBlackEtch_DataType4G.png
./WhiteOnBlackEtch_DataType4G@2x.png
./WhiteOnBlackEtch_DataType4G_2only_.png
./WhiteOnBlackEtch_DataType4G_2only_@2x.png
./WhiteOnBlackShadow_DataType4G.png
./WhiteOnBlackShadow_DataType4G@2x.png
./WhiteOnBlackShadow_DataType4G_2only_.png
./WhiteOnBlackShadow_DataType4G_2only_@2x.png
(remove ./)

And

Code:
./ColorOnGrayShadow_DataTypeLTE.png
./ColorOnGrayShadow_DataTypeLTE@2x.png
./WhiteOnBlackEtch_DataTypeLTE.png
./WhiteOnBlackEtch_DataTypeLTE@2x.png
./WhiteOnBlackShadow_DataTypeLTE.png
./WhiteOnBlackShadow_DataTypeLTE@2x.png
This would change the appearance of the LTE and 4G logo. I did this myself. I haven't had time to check in iOS 7 though. If you find in which folder there are these images, I guess you can change 4G to LTE easily.
 
Comment

hharzer

macrumors member
Jun 18, 2013
69
0
You're using Telenor SE, don't you?

Did you respring and/or reboot? Are the settings still there after you did this?
 
Comment

hharzer

macrumors member
Jun 18, 2013
69
0
Okay that's strange because I couldn't find an override for the data indicator of LTE in 3's carrier bundle... Are you sure you're in an area that's covered by LTE? Some carriers replace H+ ( not shown by iOS ) with 4G ( at least I figured as much ;) )

Someone reported that it worked... I'd've a look at your carrier bundle but I had to restore my phone ;)
 
Comment

dasx

macrumors 65816
Jun 18, 2012
1,098
17
Barcelona
Send me the carrier.plist from your carrier bundle, I can edit it for you to display LTE
Actually that's pretty simple!

If you OP have iFile, browse to System/Library/Carrier Bundles/iPhone/ and look for your carrier's plist. Then edit it and change:

Code:
<key>DataIndicatorOverrideForLTE</key>
<string>4G</string>
to:

Code:
<key>DataIndicatorOverrideForLTE</key>
<string>LTE</string>
You can even edit what the Status Bar says. No need for tweaks.
 
Comment

robertkarlsen

macrumors 6502
Original poster
Aug 13, 2011
259
45
Halmstad, Sweden
Actually that's pretty simple!



If you OP have iFile, browse to System/Library/Carrier Bundles/iPhone/ and look for your carrier's plist. Then edit it and change:



Code:
<key>DataIndicatorOverrideForLTE</key>

<string>4G</string>


to:



Code:
<key>DataIndicatorOverrideForLTE</key>

<string>LTE</string>


You can even edit what the Status Bar says. No need for tweaks.

No such string to edit in my carrier.plist :(
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.