get rid of a program resident in memory

Discussion in 'Mac Apps and Mac App Store' started by Aardenon, Aug 24, 2011.

  1. Aardenon macrumors newbie

    Joined:
    Feb 11, 2011
    #1
    Hi,

    I have a problem with GoogleUpdateInstaller. I tried to install Picasa, but the install failed. Now once in a while I get a popup to allow GoogleUpdateInstaller to make changes, if I confirm, the installer fails/hangs again, if I refuse the same window will popup again in a while.

    So the whole Picasa installation fails and a window keeps popuping up trying to install the Updater.

    How can I now get rid of this installer. It doesn't appear in the dock as a separate app, it doesn't appear among apps when I Cmd+Tab through them. It is somehow resident in memory and keeps popping up. Is there something like a TaskManager in Windows so that I can kill a process? Or maybe it is written in some config file, to popup every once in a while? I keeps on happening after restart too. How can I get rid of it?

    Can anyone help?
    Thanks
    PR.
     
  2. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #2
    The equivalent to Task Manager is Activity Monitor, which you can find in Applications/Utilities.

    Highlighting the process and asking to Inspect it should give you some clues as to where it lives when it's not annoying you.
     
  3. rowley macrumors 6502

    rowley

    Joined:
    Dec 16, 2008
    Location:
    London, UK
    #3
    To stop it from starting up each time you log in too

    System Prefs > Accounts > User > Login Items

    remove it from the list there.
     
  4. Aardenon thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #4
    Thanks for the tips. Now in the activity monitor I found Google Updater Helper process which I killed, we'll see if it's the annoying popup. But in the startup items (System Preferences > Accounts > User > Login items) I still have Google Updater Helper but disabled - gray and not checked, I can't delete it. Any cure for that?

    Cheers,
    PR.
     
  5. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #5
    Have you tried selecting it and pressing the minus button?
     
  6. Aardenon thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #6
    The minus is disabled - gray as well (on that item). Is it possible to hack into some file or something where this config is kept?
     
  7. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #7
    check the padlock on the screen, make sure it's not locked
     
  8. Aardenon thread starter macrumors newbie

    Joined:
    Feb 11, 2011

Share This Page