Getting 16xx errors trying to restore 3GS

Discussion in 'Jailbreaks and iOS Hacks' started by Mr. Bungle, Oct 14, 2009.

  1. Mr. Bungle macrumors newbie

    Joined:
    Oct 14, 2009
    #1
    I have tried restoring to factory settings with Windows XP and Itunes 9. It goes through all the processes and puts my phone in DFU mode (USB cable to Itunes Icon) Then after a while it gives me an "Unknown error 1604" (I think it said 04) and stays in DFU mode. (Had to get ireb to get it out of loop) Anyways I know there is an alternate way to do this on the phone itself. Is this what I need to do or does anyone have any suggestions? I jailbroke my 3gs with redsnow on 3.0.1 firmware, and I also have the MMS update.
     
  2. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    I think there is more to this than meets the eye.
    I do not think the 3Gs can be restored to 3.0 since the firmware is no longer signed, unless you hve the ECID and SHIH on file with Saurik and you redirect t his server.
    Otherwise you have to upgrade to 3.1.X

    I could be way off on this.
     
  3. Mr. Bungle thread starter macrumors newbie

    Joined:
    Oct 14, 2009
    #3
    I can't even upgrade to 3.1.X it still gives me the same error.
     

Share This Page