Getting a no longer available app...

Discussion in 'Jailbreaks and iOS Hacks' started by whyrichard, May 5, 2019.

  1. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #1
    Hello good peeps,

    We (my son and I) are trying to figure out if there is any way to get an ipad app which is no longer available. The Skylander Trap Team app is required to use a toy he covets, and was taken off the store last july. Is there any way to get this app running on my old ipad mini first gen?

    Thank you so much,
    Richard
     
  2. Banglazed macrumors demi-god

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
  3. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #3
  4. Banglazed macrumors demi-god

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #4
  5. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #5
    ... so I downloaded the Trap Team IPA, dragged it into itunes, and synced... and on the ipad it the icon showed up and was ready to install but at the last minute it just disappeared!

    Should i use one of the different methods? Is this because I did not purchase it before? If I didn't purchase it before is there any way to get it on my ipad?

    Thanks,
    Richard
    --- Post Merged, May 6, 2019 ---
    do i need to jailbreak my ipad? it is running 9.3.5...
    r
    --- Post Merged, May 6, 2019 ---
    by the way, thank you sooooo much for your help!!!!! a five year old will be smiling soooo much if this works!!!!
    --- Post Merged, May 6, 2019 ---
    ... by the way, thank you soooooo much for your help with this... a just turned six year old will be smiling so much if this works!!!
     
  6. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #6
    Use Cydia Impactor.
     
  7. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #7
    if I jailbreak my ipad using:

    https://pangu8.com/jailbreak/ipad/

    will it be the same method through itunes to get the app on, and it will stay on and won't disappear?

    thanks so much,
    richard
     
  8. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #8
    You can use Cydia Impactor without a jailbreak, I don't think jailbreaking will make a difference with iTunes
     
  9. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #9
    i am in cydia impactor, and i press start, and it asks for my apple id username. it says it can be my itunes email login. i tried it, but it got an error...

    ... is this safe?
    r.
     
  10. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #10
    what is the error? Impactor is used for all modern jailbreaks so it's trustworthy.
     
  11. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #11
    I am hazarding a guess that this App may still be available in your App Store purchase history.
     
  12. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #12
    Never bought it! But need it now
    --- Post Merged, May 6, 2019 ---
    I never bought it. That’s the issue...
     
  13. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #13
    the error says

    File: provision.cpp; line: 173; what:

    Please sign in with an app-specific password. You can create one at appleid.apple.com.

    this, after i used my usual mac id, the one i use for the app store and icloud, etc. is that correct?

    And to be clear, I do not have to do anything to my ipad before using Cydia Impactor... yes?

    thanks, getting closer!
    Richard
     
  14. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #14
    Follow that link and under Security you can generate an app-specific password. Use that password with Impactor.

    As long as the iPad is not locked you don't need to do anything to it
     
  15. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #15

    ... got a step further, and when Cydia Impactor seems to accept my mac user id and my app specific password, i get the error message:


    Do i need to enroll as a developer? sheesh... Thank you all again for your patience and persistence!
     

    Attached Files:

  16. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #16
    I'm not sure what is causing you all these problems honestly. For me I just enter my old Apple ID and password, then it goes through without issue.

    If you have another Apple ID I would try that. Perhaps delete Impactor and reinstall. What macOS/iOS versions are you running?
     
  17. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #17
    I didn't realize i needed to drag the IPA file into the impactor window! Thanks so much everyone!!!!!
    --- Post Merged, May 8, 2019 ---
    my never ending saga....

    okay, so figured out that I need to drag the IPA file into the impactor window. it installed, but it says "Device is not Supported" when opening the app. I thought it was! Ipad mini first gen.

    So, I tried installing it on my new iphone xs, and i got a new error message:
    --- Post Merged, May 8, 2019 ---
    would an ipad mini 2 work?

    r.
     

    Attached Files:

  18. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #18
    Looks like it's a 32-bit app so it will not run on iOS 11 or newer. What iOS version is the mini you are attempting the install on running?
     
  19. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #19
    sa
    i tried it on a ipad mini 2 running 12.2, and a ipad mini 1 running 9.3.5. the mini 1 got the above message, the mini 2 got this one...

    r.
    --- Post Merged, May 15, 2019 ---
    do i need an iphone 4 or something like that?
     

    Attached Files:

  20. Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    USA
    #20
    Only your mini 1 would/should work for 32 bit only apps.
    Can you attach a screenshot where you get device is not supported?
    Have you looked in settings/general/profiles yet?
    Have you tried to create a new generic Apple ID (without 2 step/factor security enabled?)
     
  21. retta283 macrumors 6502a

    retta283

    Joined:
    Jun 8, 2018
    Location:
    Kingman, AZ
    #21
    I don't get the SA or the R part of this post. Perhaps the app is not iPad compatible at all. If you have an old iPod touch or iPhone lying around you should try it. At this point, either it's not compatible or your IPA is bad.
     

Share This Page

20 May 5, 2019