Getting a terminal window?

Discussion in 'macOS Sierra (10.12)' started by davvanc, Mar 29, 2017.

  1. davvanc macrumors member

    Joined:
    Oct 29, 2015
    #1
    If I recall correctly, in El Capitan when you clicked on the Terminal icon in the dock, a shell window just opened up by default.
    Now in Sierra 10.12.4, I have to click on the Shell menu and select new.
    Is that a setting somewhere?
     
  2. BLUEDOG314 macrumors regular

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #2
    This isn't an issue for me. Perhaps try deleting ~/Library/Preferences/com.apple.Terminal.plist and see what happens after a reboot.
     
  3. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #3
    I get a window open automatically. Looking at the preferences, it looks like your choices on startup are to open a window or a window group-- I don't see a preference to not open anything. I agree with @BLUEDOG314, there's probably something wrong with your config.

    I've had problems with other applications opening windows off screen if I change between my laptop display, an external display, or dual display. Could that be happening?
     
  4. davvanc thread starter macrumors member

    Joined:
    Oct 29, 2015
    #4
    Tried that, no change. Even tried rebooting from a backup El Capitan partition, same thing happens. It is not a big deal as clicking on the Shell/New Window menu opens up a window.
    Still, something isn't right. :apple::(:apple:
     
  5. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #5
    Are you actually quitting Terminal.app with Apple-Q or are you just closing the terminal window? Closing the terminal window will not quit Terminal.app.
     
  6. davvanc thread starter macrumors member

    Joined:
    Oct 29, 2015
    #6
    Of course, I am actually quitting the app, with Apple-Q. The issue is it does not respect its own prefences, ie., to open a shell window by default on startup.
    Happens in both El Cap and Sierra.
     

Share This Page