getting an error when copying a large file to my external drive

Discussion in 'Mac Accessories' started by mrgreeneyes, Jun 9, 2009.

  1. mrgreeneyes macrumors 6502

    Joined:
    Oct 7, 2007
    Location:
    Orleans,Canada
    #1
    hi,

    every time i try to copy a file that is over 6gb to my external drive i get this message

    "sorry, the operation could not be completed because an unexpected error occurred. (error code 0)

    how di i fix this error?

    thanks a bunch
     
  2. Blackjack07 macrumors member

    Blackjack07

    Joined:
    May 15, 2009
    Location:
    Belgium
    #2
    When I get trouble with my external or flash drive I'd rather never take risks, so I always get all my files off, and just use the Disk Utility, and format the drive. Most problems get solved doing this.
    You could google it, and run down some threads started on other forums, but thats up to you...

    good luck

    B07
     
  3. mrgreeneyes thread starter macrumors 6502

    Joined:
    Oct 7, 2007
    Location:
    Orleans,Canada
    #3

    see my problem is that, my drive is a 1TB drive and its full of family photos and videos and backups. and i dont have another drive to copy everything to
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    Is your external formatted FAT32? If so this is a file size limitation of the file structure and you'll need to format it HFS+
     
  5. bobnugget macrumors regular

    Joined:
    Nov 15, 2006
    Location:
    Kent, England
    #5
    Hi,

    Is your external drive formatted as HFS+ (Mac format) or FAT32 (old PC format)? Most drives come formatted as FAT32, and do not support files larger than 4GB. You get a similar error to this if that is the case. The new PC format (NTFS) does support larger files, but Macs can't write to it without a system extension.
     
  6. donsherio macrumors newbie

    Joined:
    Jun 15, 2009
    #6
    On this explains it...

    So FAT-32 doesn't do files over 4GB eh? Hmmmmm that might also explain why my other 200GB+ external drive couldn't accept this 6GB file on Windows. ... Well I'm screwed. My drive is a 1TB external so I'm in the same boat as the OP with all my life's works on it and no other storage options so that I can re-format the drive. BLARG...
     
  7. brooksykes macrumors newbie

    Joined:
    Oct 18, 2009
    #7
    i had the same problem when trying to copy a series of video files and folders adding up to 70 GB roughly, i overcame this problem temporarily by copying them folder by folder... i then noticed that the error message only appeared when i tried to copy a .ISO file which was included with the video files. i don't know why this happens but i mounted it and am now copying the files from it one by one.
     
  8. kennedyd007 macrumors newbie

    Joined:
    May 17, 2010
    Location:
    San Francisco
    #8
    Workaround for copying large files to external Fat32 formatted drives (error 0)

    Stuffit allows you to break up files into any size segment and then move the pieces under 5GB (say 4.9GB each) to the Fat32 Drive. It reconstructs it like .rar does (or just do a .rar compression but stuffit doesn't seem to have that).

    Fat32 drives seem to be a necessary evil for people with media players (I use the Asus HDP-R1 Media player with USB or eSata drives with movies/music i download--plays them right to stereo system or flat screen, no running expensive cables out of the back of my mini anymore). For 80 bucks, it's pretty sweet (though i do recommend the Western Digital unit--way better interface). The Fat32 Drive format is the most native for the Asus but will recognize HFS too i'm pretty sure. I just have a PC and a mac I download movies/music to and move the drives around a lot between them.
     
  9. dexplore97 macrumors newbie

    Joined:
    Mar 10, 2010
    #9
    another workaround

    I couldn't copy a .dmg file (4.66GB) to my FAT32 formatted USB drive. I dbl-clicked it to mount it and I tried copying the contents to my USB drive (4.8GB) and it worked. It copied error free. It seems that you just can't copy archive files (.zip, .dmg, .rar) larger than 4GB. Weird, huh?
     
  10. gillpar macrumors newbie

    Joined:
    May 7, 2009
    #10
    Thanks for the good answers

    Thanks dexplore97, the mount then copy solution worked a charm for me. :)
     
  11. leobunch macrumors newbie

    Joined:
    Jul 30, 2010
    #11
    What you mean mount and copy. please tell me how to do that.

    would you please tell me how to mount and copy. i mean dexplore97 done well explaining an option which might work, but was your option different. can you please write me how to mount.

    thank you
     
  12. DooGesWiZrdOfOz macrumors newbie

    DooGesWiZrdOfOz

    Joined:
    Feb 24, 2010
    Location:
    Sydney
    #12
    Thanks dexplore97, Your's is the gift that just keeps giving. This issue has plagued me for weeks, but I have my life back and can return into the sunlight with squinted eyes. Cheers
     
  13. cpguru21 macrumors newbie

    Joined:
    Jan 12, 2010
    #13
    My guess is that each of the files within the archive were below the single file size limitation of FAT32 and that is why this appeared to *Solve* the problem.

    hmmm I see im responding to an old thread. Oh well hope this helps someone else.:D
     
  14. bfg67 macrumors newbie

    Joined:
    Jun 14, 2011
    #14
    thanks for fix

    it certainly did. had multiple isos in a folder - to large to copy whole folder, but went over individually fine. the whole folder copied over to my time machine disk (for a temporary test), just not my FAT32 - here's me thinking fat32 is the 'best' format!
     
  15. vbrosso macrumors newbie

    Joined:
    Sep 24, 2011
    #15
    SOlution

    Rename your folder for "*.zip" and try!
     
  16. gr8gazoo173 macrumors newbie

    Joined:
    Aug 29, 2011
    #16
    ExFat format will allow transfer of larger files. Works well with the Mac. Not supported in Windows 7. But did find a patch for Windows XP.
     
  17. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #17
    Regardless of the fact that you're responding to a thread from last year, exFAT IS supported by Windows 7. It was developed by Microsoft so it would be odd for Windows 7 to not support it.
     

Share This Page