Resolved Getting Error (-50) while trying to update to iOS 5.

Discussion in 'iOS 5 and earlier' started by botsmack, Oct 12, 2011.

  1. botsmack, Oct 12, 2011
    Last edited: Oct 12, 2011

    botsmack macrumors member

    Dec 16, 2008
    Birmingham, AL, USA
    I'm using an iPhone 4 running iOS 4.3.5. Tried to install iOS 5, but received the following error after about 5 minutes attempting to back up:

    Of course, I don't want that. The phone has never had upgrade problems before and it's never been jailbroken. Any ideas? Mac is running 10.7.2 and iTunes 10.5. iTunes is set up for encrypted backups.

    I tried turning off the encrypted backup as well as deleting the backup and letting the upgrade process create it. Nothing helps! I should note that I can create a manual backup without problems and it syncs fine. I had posted this over at Apple's discussion forum, but their site is running super slow at the moment.

    Edited to add:

    We're getting somewhere. I had my MobileSync folder symlinked to my HDD to keep it off my SSD. I moved it back to the SSD and the backup portion of the iOS 5 upgrade worked. Now I'm getting this error:

    After doing the backup, the iOS 5 upgrade goes through "Extracting software" and finally "verifying iPhone restore with Apple." It's during that last message that the internal error occurs. Reading over at Apple's forums suggests that this is an issue with Apple's servers getting hammered right now and after 5 or so attempts it finally upgraded for them. I'll just keep at it.

    This iOS upgrade has been the worst Apple upgrade I've ever experienced, which is a good thing, because it doesn't happen a lot, but still. This sucks!

    Second Update:

    Looks like I got past the verification step and it's proceeding with the upgrade. Yay!
  2. briananderson macrumors member

    Jul 1, 2007
    I'm getting the same error. I have my MobileSync folder symlinked too, and its been so long, I can't remember how to restore that. How'd you do it?
  3. rebby macrumors 6502

    Nov 19, 2008
    I've been getting this error as well. I had ~/Library/iTunes symlinked to my HDD. I just moved this directory back to the SSD. Wish me luck!
  4. botsmack thread starter macrumors member

    Dec 16, 2008
    Birmingham, AL, USA
    Yes, just delete the symlink "folder" and copy the folder with the data back over.
  5. ziresta macrumors newbie

    Oct 12, 2011
    Thank you for posting how to fix this. I'd been getting this error too and everything I could find about it seemed to indicate it was the cable's fault, and when it didn't go away after I switched cables, I was getting worried. But, now I've got iOS 5 installed successfully.

    Now if I can just figure out why iTunes isn't giving me the option to sync via wifi . . .
  6. dgoss macrumors regular

    Apr 19, 2004
    Los Angeles, CA
    can you restore symlink after?

    I was enjoying keeping my backups off my macbook air and symlinked to my network drive. After getting rid of the symlink and updating, do things work properly with the symlink back in place or is this a way of the past? Any of you symlink-ers try after your update?
  7. mgipe macrumors demi-god


    Oct 6, 2009
    I encounter the same error while trying to update my iPad to iOS5. I don't have a symlink set up. The backup file is in its default location.

    Any ideas? I certainly don't want to "lose all contents on this iPad."

Share This Page