Getting failed :( message, every time try to jailbreak iPod Touch 2G with Greenpois0n

Discussion in 'iPod touch Hacks' started by infobleep, Jan 1, 2011.

  1. infobleep, Jan 1, 2011
    Last edited: Jan 1, 2011

    infobleep macrumors regular

    Aug 10, 2008
    Dear all

    This question may have already been answered elsewhere but I've spent all evening trying to resolve this issue with the help of searching and reading Web Pages but I can't resolve it.

    I never bothered with Jailbreaking my iPod but now I wish to take off some recordings I made using TuneInRadio and the only way to do this is to Jailbreak my iPod.

    I have an iPod Touch 2G which isn't an MC model because it starts with A, as engraved on the back. Actually that is wrong. It is an MB model but only because it was part of the 2nd generation releases and therefore doesn't have the same bootROM as the 3rd generations. This piece of information is not obvious when jailbreaking sites go on about MC and non-MC 2G iPod Touches. It is as if they assume everyone knows the difference. I may be technically minded but without reading something first it's much harder to know any difference.

    Anyway the iPod I'm using has iOS 4.1 so in theory jailbreaking with Greenpois0n should be easy. However and correctly me with I'm wrong, I believe no other jailbreaking application offers untethered use of the iPod 2G. So I downloaded Greenpois0n for my Mac, which is running Snow Leopard and iTunes 10.1 (54).

    There is a help video at and this explains how to use Greenposi0n.

    The problem I have is that every time I run the programme and follow the instructions I get the wording "failed :(" or if running a 2nd time it will quit with an error message. One comment on the YouTube page suggests doing a restore but the problem with doing a restore is that it will put iOS 4.2 on my iPod and then I definitely won't be able to jail break.

    Does any one else have any ideas? Has anyone else had the same problem. I know the program works for many other people but I can't get passed the failed message or the program quitting.

    Kind regards
  2. Mac Fan 4 Ever, Jan 1, 2011
    Last edited by a moderator: Jan 2, 2011

    Mac Fan 4 Ever macrumors regular

    Dec 8, 2010
    I'm not so sure what the problem is, if you could explain exactly what's wrong, I can help.

    If not, if you do choose to restore, you can "downgrade" to 4.1
  3. infobleep, Jan 2, 2011
    Last edited: Jan 2, 2011

    infobleep thread starter macrumors regular

    Aug 10, 2008
    Thanks for your reply Mac Fan 4 Ever.

    The things is, I actually don't know what the problem is myself. Short of posting error message log that appears on screen, which relates to the crashing of Geenpois0n itself, there isn't much I can add. All I get in greenposi0n itself, is a message saying failed :(. I do get the blank screen on my iPod Touch but can't get beyond that stage.

    I actually have 4.1 installed already. I've yet to upgrade because it's been some weeks since I last connected my iPod to my laptop. Although I did back it up yesterday, I didn't install iOS 4.2 because I wasn't sure if it would stop me being able to jailbreak.

    As it is I now believe that RedSn0w will work. I was going to use this originally but at one point I got the impression it wouldn't work untethered. This was probably because I didn't fully understand what tethering meant and at that point I didn't know what non MC and MC meant, the sites not actually explaining the difference. Not surprising when you read the following 2 quotes from the same Web Site. This being just one example of the confusing messages put out.

    Front page of, which contains a tutorial below.
    "How to Jailbreak Your iPhone iOS 4.2.1 with RedSn0w
    RedSn0w was recently updated to jailbreak iOS 4.2.1. While this is excellent news, it doesn’t come without its drawbacks as only the iPhone 3G, older iPhone 3GS, and non-MC iPod touch 2G get the untethered jailbreak."

    From there tutorial page, a different tutorial to the one on the front page ( jailbreak.html)
    "How to Untether Your iPhone 4.2.1 Jailbreak with RedSn0w
    Update #4
    We’re aware that some of you are true dare devils so we thought it’d still be a good idea to post a guide on how to untether your iPhone. This step by step tutorial will show you how to untether your iPhone 4.2.1 using RedSn0w. This only works for the iPhone 4, iPad, and iPod Touch 4G…"

    Both guides tell you to download the beta 4 version of the software. Both guides are different so it may will be that the tutorial page guide is for 4G users and some other modern models and the front page guide is for some older models. However none of the page titles tell you this and both claim it does not work for other devices without saying but use the other guide which does. I'm just picking this Web Site as an example. Others exist offering similar confusing messages.

    I know people don't want Apple to know how they exploit their loopholes but there must be a more coherent way the information, on what is possible jailbreaking wise, could be presented. Actually I have now found a useful table on Wikipedia ( and it shows that 2G iPod Touch cannot be untethered for iOS 4.2 using the latest version of Redsn0w but can be using a slightly earlier version. I've been using computer for many years, so I'm no novice, and I have found all of this rather confusing. I doubt some of my friends would have a clue. Perhaps jailbreaking is just intended as a challenge for computer geeks like myself.

    Anyway I will cease my moaning because life's to short and just add that RedSn0w will work with iOS 4.2 but you need to install a slightly older beta version for it to work with iOS 4.2, for the MB model 2G iPod Touch, according to Wikipedia. I'll have to go and check which version of redsn0w I downloaded and get the correct one from somewhere.

    Kind regards
  4. Mac Fan 4 Ever macrumors regular

    Dec 8, 2010
    Well, surprisingly, I just jailbroke my MC 2G iPod Touch on, Thursday with Greenpois0n. It was very easy. This site helped me out in what program to use:

    I'm not sure if it's the directions on the screen that you're misunderstanding in Greenpois0n, because it did take me a couple of tries to get it right. You have to click jailbreak before you hold all the buttons and all that stuff lol.

    Good Luck this time!

  5. infobleep thread starter macrumors regular

    Aug 10, 2008
    According to Wikipedia, not that it's unknown for it to wrong, it states that Greenposi0n works for MC but under software to use for MB models, it just lists redsn0w 0.9.6b6 - not that I've come across beta 6 myself. However it does list 2G without stating which type, under the greenpois0n entry.

    So whether it was a MB model issue with Greenposi0n or just my device itself, I don't know.

    What do know is that I got Redsn0w working and for the benefit of others, here is a step by step guide to what I did. Hopefully this will be of use as I got quite confused myself.

    The following guide works for iPod Touch and 2nd generation devices with the model MB.

    To find the model number you go to:
    settings -> about

    It will then either list MB or MC. MC was for all 2nd generation 8GB iPod Touches that were released when 3G touches came out. You may even think it is a 3G, given that, as far as I could tell, Apple seemed to class it as such in the general promotion. The MC model contained an update to the bootROM. This is why my guide is only for the MB model as I don't have an MC model.

    Make sure you have iOS 4.1 installed. I haven't tested this with any other iOS.

    So firstly download Redsn0w version 0.9.6b4. It is available at the following Web Site:

    One downloaded unzip it. I use a programme called The Unarchiver to unzip my files on my Mac. If you don't have that you can get it from here:

    Once unzipped run Redsn0w app. Now Redsn0w needs to find the firmwire of your iPod. This is your iOS 4.1. Despite showing all hidden files on my Mac, I could not locate this file, even though I had read what the correct locations for the folder should be. It is a file with .ipsw extension and even searching for that brought up nothing.

    However Apple have the file I required on their Web Site, so I simply downloaded it. You can do so from their Web Site but using the following link:,1_4.1_8B117_Restore.ipsw

    The ipsw file is just for the iPod Touch 2G and not other iPods. If you looking for ipsw files for those then the links are at the following Web Site:

    I must add though that my guide is just for the MB models of 2nd Gen Touch, not any other Touch model.

    Once downloaded I was able to tell Redsn0w where the ipsw file was, which was in my downloads folder.

    I was then presented with some options. Cydia was one I wanted so I ticked it. I didn't need the Custom Bundle so didn't tick that. It took sometime to find out what Custom Bundle meant. It is something which allows developers to add their own apps with using Cydia or similar applications. That is what I believe, based on the few references I could find to the term.

    I wanted the verbose log so I could read all the commands apple run to load my iPod. However this isn't essential and if you perfer not to see all the code as it starts up, turn it off.

    You can add your own custom logos for the start up and the recovery modes but I chose not to. It had taken long enough just to get this far.

    You can also tell it to allow background wallpapers. I forgot to tick this on myself.

    There is an option to allow multitasking which is worth ticking on As is the option to see how much battery life remains.

    Once done you then follow all the instructions which are either much clearer than Greenpois0n or my iPod simply didn't work with Greenpois0n's app. Perhaps a bit of both.

    Once installed go to the cydia application. Allow it to fool Apple into thinking you have a later iOS. This is useful when new iOS's come along that cause jailbreaking to no longer work.

    Once done go down the list to Copying Files to/from Device. Once here click on the link Netatalk. This installs a program on your iPod which allows it to be seen in Finder on your Mac. If using Windows then install iPhoneBrowser, which is a link further down. These programmes connect wirelessly to your iPod and not via the USB cable, so don't expect it to be as fast.

    Once installed restart your iPod. If under shared [devices] in Finder your iPod doesn't appear, restart your Mac.

    Now the iPod should appear under your shared devices in finder.

    Click on it and you will be prompted for a username and password. The password and username are not any password or username you use but one Apples gives to protect the device. It is the same username and password for all devices.

    The username is: root
    The password is: alpine

    This then gives you access to the device in finder. In my case I wanted some recordings from TuneInRadio. These are located within the root directory in a sub folder. This I believe is the directory that had been password protected with alpine password.

    Applications are stored in various folders but the folder required for TuneInRadio is under the following:


    Within Applications are loads of folders with codes. Each of these is a different application. You just have to go through them all until you find one with the TuneInRadio file.

    Once that is located, you will find a Documents folder within the same directory. Copy this to your Mac. In my case it was 3GB so it took 40 minutes to copy.

    Now on your Mac go to it. Within Documents you will find sub folders. In each of these sub folders are png files, xml files and files number extensions. e.g. .1, .2, .3 etc. The number extensions are mp3 files. The png are the pictures stored when recording and the XML files tell TuneInRadio which order to play the recordings and which pictures to display etc.

    To play the recordings on your Mac you need to change all the extensions to mp3. Either find a programme which does this automatically or do it manually. I have a Windows program I use to do it automatically [I run Windows as a Virtual Machine but that is outside the scope of his guide].

    Now you have the recordings accessible and in my case I can recover 3GB of space, which is a large amount, when I only have 8GB to start with.

    I hope I have not missed out any steps and that this makes sense to others. I was going to write a step by step for myself anyway so it made sense to make it public for others. You can do much more with jailbreaking but that is all I required at this time. The multitasking will be useful for running TuneInRadio but that's about it for me personally.

    Kind regards
  6. Mac Fan 4 Ever macrumors regular

    Dec 8, 2010
    Glad you got something to work!

    And btw, you make the longest posts! lol

Share This Page