Getting hard drive space back, after deleting a boot camp partition

Discussion in 'Windows, Linux & Others on the Mac' started by Panacea, Dec 27, 2009.

  1. Panacea macrumors newbie

    Joined:
    Dec 27, 2009
    #1
    I recently got rid of a partition I had made for bootcamp since I never use it, and would rather have the space back.

    I deleted the partition through disc utility, and then through the partition tab, tried to get back that space by dragging down the tab to restore the space originally set for the partition.

    When I go to apply this change, it notifies that my hard drive will be re-sized. I accept and then a few minutes later it comes back with the error "Partition failed with the error: Filesystem verify or repair failed"

    Does anybody know how I can restore this space successfully back into my main hard drive?

    I've attached some screenshots if its any help.
     

    Attached Files:

  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    The issue may be the fact that the two partitions are different file systems, you could try formatting the old windows partition to hfs+ or whatever your mac so x drive is formatted as.

    If you run boot camp assistant there is, iirc, an option to merge back into one, I would try running that first.
     
  3. Panacea thread starter macrumors newbie

    Joined:
    Dec 27, 2009
    #3
    When I run bootcamp assistant it only gives me the option to partition the drive all over again. the iirc option you mention is nowhere to be found. How were you able to access it?
     
  4. Panacea thread starter macrumors newbie

    Joined:
    Dec 27, 2009
    #4
    Still no luck. Does anybody have any other suggestions?
     
  5. El Burro macrumors regular

    El Burro

    Joined:
    Sep 7, 2009
    #5

    You're better off reinstalling entirely if you want that space back. You don't want to risk any corrupt data space.
     
  6. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #6
    err, well I can't tell by the SS and you didn't state so I'll ask. You're trying to do this using the install CD and not while you're using the partition, right?
     
  7. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #7
    Agreed. By removing the partition manually in Disk Utility, the Boot Camp Assistant doesn't know how to put the partition back the way it was. Your best bet is to restore from your Time Machine backup (you have one of those, right?) after manually reinstalling the operating system (remember to repartition!).

    When working with partitions, it's just too easy to screw everything up. That's why you have to rely on third-party utilities in the PC world -- Microsoft doesn't want you to dynamically repartition drives because of the probability of data loss.

    -Aaron-
     
  8. ddaedalus macrumors newbie

    Joined:
    Nov 4, 2010
    #8
    Been there

    I had the same thing happen: I created a partition, removed it and found that the original (root) HD size had shrunken. There was sort of a gray area where the previously partitioned area had been. I noticed that within Disk Utility, some of the options were not selected, such as changing the name of the (root) HD, etc.

    What I did was simply click on the 'size' input and type in what the total size of the root HD--which was 500 (GB), and the partition extended and even corrected me to 499.63, then I clicked 'apply'

    Good Luck,
     
  9. Rodus macrumors 6502a

    Rodus

    Joined:
    Oct 25, 2008
    Location:
    Midlands, UK
  10. fried-gold macrumors member

    Joined:
    Nov 9, 2008
    Location:
    Berlin
    #10
    Hello,

    I have a similar problem, but one slight drawback I am in Berlin and my osx install disk is in scotland. I can get some to post it out but its a bit of a hassle. Anyone know of another solution, or possibly some third party partition software i can use to erase the partition?

    Regards,

    Andy
     
  11. fried-gold macrumors member

    Joined:
    Nov 9, 2008
    Location:
    Berlin
    #11
    Nevermind, rebooted in single user mode and ran fsck, seems to have done the trick. Right c'mere boot camp, and none of your jip this time.
     
  12. mutech macrumors newbie

    Joined:
    Feb 10, 2015
    #12
    I had the same problem. What solved the issue for me (on Yosemite) was to split the OS X partition and then removing the new partition again. As a result, the first partition was sized to take up the whole space (the newly split partition and the empty space formerly used by bootcamp).

    Quite a frustrating experience, at least with a happy end in my case... :apple::eek:
     

Share This Page