Getting lots of "The first time" warning at system startup after upgraded to DP6

Discussion in 'OS X El Capitan (10.11)' started by leon.guan, Aug 4, 2015.

  1. leon.guan macrumors newbie

    Joined:
    Jun 14, 2010
    #1
    After upgraded to DP6, I am getting messages like:

    ```
    You are opening the application “Bartender” for the first time. Are you sure you want to open this application?
    ```

    at each system startup. I have to click confirm for all of dialog. And they will come back at the next boot up.

    Tried to rebuild the launch services, clean caches, no luck.

    Any hints for getting this annoy issue resolved?
     
  2. realpras macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #2
    I have this issue, too. Every app I choose to open on startup shows this popup notification. Fix to this issue would be much appreciated.
     
  3. leon.guan thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #3
    I already reverted to DP5, and I am seeing someone else having the same issue, really annoying.
     
  4. peymayesh macrumors newbie

    peymayesh

    Joined:
    Jun 20, 2012
    Location:
    /bin/
  5. philipk macrumors 6502

    Joined:
    Jun 11, 2008
    #5
    Same problem on only two start-up programs - Dropbox and MacID.
     
  6. hojx macrumors 6502

    hojx

    Joined:
    Jan 18, 2014
    Location:
    Singapore
    #6
    I have about eight apps that are doing this.
     
  7. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #7
    Public Beta is the same. I ended up uninstalling and reinstalling the offending apps and it solved the problem.
     
  8. AngerDanger macrumors 68030

    AngerDanger

    Joined:
    Dec 9, 2008
    #8
    Have you tried toggling this between Mac App Store and identified developers and Anywhere?

    Screen Shot 2015-08-05 at 2.44.17 PM.png
     
  9. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #9
    That didn't make any difference for me with the PB release. Same thing happened.
     
  10. leon.guan thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #10
    It's not that issue, looks like it's caused by Bartender latest beta version (1.3.1), if you followed the instructions indicates here: http://www.macbartender.com/system-item-setup/

    I got those error messages after do those steps.
     
  11. iCloudStrife macrumors member

    iCloudStrife

    Joined:
    Jun 15, 2015
    #11
    This has happened to me with every app on every Developer Preview. I thought it was normal.
     
  12. dfran1 macrumors regular

    Joined:
    Apr 18, 2008
    #12
    I have the same problem on my macbook pro BUT no problem with my mac pro, so this is not normal.
    I think it is a permission problem, because I also could not add safari extensions until I fixed the permission on that folder.
    So now that apple removed the permission fixing, what program can I use to fix permissions that may actually fix this problem, PLEASE!!
     
  13. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
  14. Flat Six macrumors newbie

    Joined:
    Jul 14, 2012
  15. dfran1 macrumors regular

    Joined:
    Apr 18, 2008
    #15
    So far totally removing, reboot, and reinstall did nothing.
    I tried the permissions reset app to a few and nothing.
    I tried manually changing permissions and nothing.
    Unless I am not finding what it needs??

    I do know I loaded the beta on both my macbook pro and mac pro the same day and all updates when they came out the same day, BUT my mac pro does not have this issue at all and the same apps I use on it.
     
  16. dfran1 macrumors regular

    Joined:
    Apr 18, 2008
    #16
    I figured it out (well sort of)
    I have duplicated the problem on both my macs.
    This only shows up when you
    - system preferences
    - security & privacy
    Put a check mark in the box labeled "Disable automatic login"
    Uncheck it and no first time pop ups, check it and they pop up all over again on reboot and restart.
    I filed a report with apple I suggest you all do also, PLEASE.
     
  17. peymayesh macrumors newbie

    peymayesh

    Joined:
    Jun 20, 2012
    Location:
    /bin/
    #17
    Also 'Ambient light compensation' is always checked when I login!
    It's very annoying :(
     
  18. Mackker macrumors member

    Joined:
    May 22, 2015
  19. shafnitz macrumors newbie

    Joined:
    Aug 30, 2011
    #19
    I'm having this issue as well. Additionally, many of my startup items weren't running at a all.

    I ended up booting into recovery mode and reinstalling base El Capitan (not formatting) and then updating up to public beta 2. Everything is back to normal now, so I'll keep it this way and hope the next public beta fixes this issue.
     
  20. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #20
    This worked for me as well. Sending feedback.
     
  21. shafnitz macrumors newbie

    Joined:
    Aug 30, 2011
    #21
    I don't see a "Disable automatic login" check box. Perhaps some other setting removes that option?
     
  22. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #22
    If you have FileVault enabled, that check box will not appear in Security & Privacy settings.
     
  23. shafnitz macrumors newbie

    Joined:
    Aug 30, 2011
    #23
    That explains it. Thanks.
     
  24. adrianlondon macrumors 6502

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #24
    I also have FileVault enabled so couldn't try the above "fix". I only had the issue with BetterTouchTool but it seems to have been cured after yesterday's update to the Command Line Tools. That could just be a coincidence of course, but the last few reboots have been clear of those messages.
     
  25. jlormsby macrumors newbie

    Joined:
    Sep 3, 2008
    #25
    I am seeing this too, but it is not for EVERY item I have as a Login Item. The following items that I have as Login Items DO NOT pop up the message.

    ChronoSync
    iTunes Helper
    AdobeResource
    Keyboard (actually Keyboard Maestro)
    NoteBookHelper
    HazelHelper
    USBOverdrive
    XtraFinder

    The following DO pop up the message repeatedly

    Mountain
    BookMacster
    ScanSnap
    Fantastical
    Dropbox
    Moom
    DragThing
    EvernoteHelp

    I submitted a but report via the feedback assistant.
     

Share This Page