Getting MySql Server out of the login box

brdoco

macrumors member
Original poster
Feb 19, 2003
37
0
I run MySql on my powerbook. After the upgrade to Panther, the MySql Server user was listed in the Mac OS X Login Box. What can I do to get it out of the login box?

Thanks,
Brian
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
You just now upgraded to Panther? From what? In the previous system, did you have a list of users that you could click on in the login box, or did you have a prompt to type in the user name?

I'm not sure there's a way to selectively hide users in the list mode.

One option is to turn off the list mode and force the user to type in a username. You can do this via System Preferences -> Accounts -> Login Options -> Display Login Window as Name and Password.

If what you want is to *delete* that user, highlight them in the Accounts pane and then click the (-) at the bottom of the column of users.
 

brdoco

macrumors member
Original poster
Feb 19, 2003
37
0
I upgraded to Tiger from Panther.

Its not a Mac OS X account, so its not going to have an entry in the Account preferences pane. Its an account in Unix, from using the adduser command, I believe.

Sidenote #1: It wasn't an available user (to log in as) in Panther. Its only been there since the Tiger upgrade.

Sidenote #2: I figured that I would be able to do something in the NetInfo Manager. I can find the user details... but nothing that would hide the login entry.
 

joenathan

macrumors newbie
Jul 16, 2005
6
0
You need to give the user a different user number. Listed users are in the five hundreds. So if SQL is 505 change it to something like 405.

This may have an impact on SQLserver though!
 

brdoco

macrumors member
Original poster
Feb 19, 2003
37
0
joenathan said:
You need to give the user a different user number. Listed users are in the five hundreds. So if SQL is 505 change it to something like 405.

This may have an impact on SQLserver though!
That's not so, evidently... The uid (and gid) is already 401.