getting "no Sim Installed" error on iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Lichter21c, Oct 10, 2010.

  1. Lichter21c macrumors newbie


    Jan 16, 2010
    The frozen tundra
    Alright, so me and my father both got iPhone 4's last monday and everything was working great until friday night. I got an error saying, "No sim installed" so of course I rebooted it, then hard reboot and neither did anything. So I completely turned it off, removed the sim card. Cleaned the connectors and then reinstalled and it. That worked all right but it happened again. Now my dad had the same problem but after reinstalling the sim it never went back to normal. Is this a common problem?? I tried looking here but I couldn't really find anything.

    any input would be greatly appreciated. also we are definitely going back to att and either getting new units or they are completely fixing it.

    thanks everyone

  2. dmk1974 macrumors 68020


    Sep 16, 2008
    I got my iPhone on launch day, and only had that happen to me on the 4th of July (like7 times...I resolved it by popping the sim back out and in) and then just the other day on Friday 10/8. Got it like 5 times that day. Popped the sim like before and then all was good UNTIL just 5 minutes ago and it happened again. I just did a reboot instead of SIM pop. We'll see how it goes.
  3. DroidRules macrumors 65816

    Aug 10, 2010
    Maybe a new sim for the both of you may be the fix. Pop on down to at&t or your provider and pick one up. Good luck.
  4. DroidRules macrumors 65816

    Aug 10, 2010
    LoL guess the joke is on me!! I'll be taking a trip to att to get a new sim as mine has done it several times in the last few hours!
  5. kelpi macrumors regular


    Sep 14, 2008
    Got the same error everyday for two weeks. Put a piece of scotch tape on the non-contact side and haven't got an error since.
  6. Surrix macrumors regular

    Jan 7, 2009
    Interesting, all of you guys too? Yeah, this has happened to me about 4 times now. Oddly, I can usually fix it by toggling Airplane Mode. It seems odd to me that this would work, given that the No SIM error sounds more like a hardware issue while toggling Airplane Mode is a software fix.

    I've also been considering trying a new SIM anyway.
  7. mcaddict macrumors member

    Apr 26, 2010
    Had the same problem, used to happen about twice a day. A reboot would usually fix it. But it was pretty annoying so i went to the apple store and they replaced the phone no questions asked.
  8. Hellishness macrumors 65816


    Jan 27, 2010
    Bay Area, CA
    My first iP4 had this. Took it to Apple, walked out with a new one in 15 minutes. See my sig...
  9. spikefood macrumors regular

    Apr 1, 2008
    Had this problem on mine as well. Got it replaced thankfully. They likely problem is that the metal part of the sim is contacting the metal tray and causing it to short. A quick temp fix is to try using a small amount of thin tape to hold the sim higher in the tray. Also, you can always go to att and get another sim, hopefully one without any movement in the tray.
  10. DroidRules macrumors 65816

    Aug 10, 2010
    Well mine literally started doing it today, after I read and posted to this thread. I was jb on 4.0.1 and tried to upgrade and got an error from iTunes. It then started happening. Updated and it has done it 2 times. If it continues I will visit ye ol apple store and swap.
  11. Surrix macrumors regular

    Jan 7, 2009
    To anyone else this is happening to: try togging Airplane Mode on and off to see it that fixes it (temporarily) for you as well. Ensure that you leave it in Airplane Mode for 2 seconds or so before toggling back, as it appears that if you toggle too quickly it doesn't finish.

    It'd be great if you could report back here as to whether or not that works for you.
  12. danh808 macrumors newbie

    Jun 29, 2010
    Had same issue today with no sim installed. Took it down to AT&T and sim card was bad. They installed a new one and everything is back to normal now.
  13. Someareteeth macrumors newbie

    Jul 10, 2010
    Having the same problem. Called Apple last week, they suggested the following steps:

    1) take sim out and put it back in (didn't work)
    2) restore phone and set up as new (didn't work)
    3) get new sim (worked so far)
    4) take to Genius Bar for new phone

    It's been about three hours since I got the new sim and it hasn't happened since. However, I'm still inclined to take it in to the Genius Bar (have an appointment in two hours) and see if they'll replace it.

    Any idea if they can tell through diagnostics if the "No Sim Card Installed" notification has happened and when? Partially I'm afraid I've missed one and partially I'd just rather they swap it out so I don't have this problem again.
  14. Surrix macrumors regular

    Jan 7, 2009
    Any update on this? Did the new SIM fix the problem for more than 3 hours?
  15. cdesigns macrumors 6502

    Aug 28, 2008
    My wifes iphone 4 had the same problem today, after searching online for a fix, I found the simcard tray fix with tape, I used their picture to show what I did on mine.

    Before this tape mod I TRIED EVERYTHING......Restore, Simcard insertion and removal several times, Airplane mode, update from 4.0 to 4.1 lets say nothing worked.

    In my case the simcard electrical contacts on the outside edge were smaller and not close to the outside edge, but I did find that the sim card electrical contacts on the side are very close to the metal tray.

    I just added a tape to make sure the simcard electrical contacts doesnt short with the simcard tray. And so far is the only thing that worked great SO FAR.

    I tried to move the simcard tray once it was installed with the tape mod and so far I havent had any problems.

    Here is a picture of what I did photoshop style
  16. cristiantm macrumors newbie

    Dec 13, 2010
    Does that fixed the issue til now?

Share This Page