Resolved Getting past password after sleep mode without providing password

Discussion in 'iMac' started by DemTM, Jan 6, 2014.

  1. DemTM, Jan 6, 2014
    Last edited: Jan 6, 2014

    DemTM macrumors newbie

    Jan 6, 2014
    Unsure if this is the right place for this, but here goes. I changed settings to the screen never going to sleep, and tested that the screen will still go black after you've activated the log-in screen that requires password after you've gone in sleep mode. Naturally, it goes black, and I don't see why I would think it wouldn't but had to try as my cats are good at activating this.

    After the password demanding screen had gone black, I was satisfied, and hit enter to come back to the screen to insert my password. But there was no need. I was already past it.
    I tested this again by going to sleep mode, letting it demand a password, let the screen go black then hit enter once more. I once again passed the need to enter a password.

    Is there something I'm missing here, is it supposed to work like this, and if it is then why exactly should it work like this? Learning this fact makes me feel unsafe about the password and feels like there's no point having one at all if I can just pass it by waiting then hitting enter. Is there some setting or...
    Currently running on OS X 10.9.1, on iMac 27" with two active profiles with different passwords.
  2. DeltaMac macrumors G3


    Jul 30, 2003
    You can change the delay until the password is required when leaving the screensaver.
    That setting is in your System Preferences/Security & Privacy pane.
    There's a drop-down for "Require Password After" where you can change to "immediately", if that's what you want.
    It's useful when you can set the screensaver (or sleep) accidentally, so you have a delay up to an hour, I think, before the system requires a password, or ANY sleep or screensaver ALWAYS needs a password to return to normal use. That setting is then your choice.
  3. DemTM thread starter macrumors newbie

    Jan 6, 2014

    Feels odd it wouldn't be immediately by default. Either way, thank you so much for the information! ^^
    It's not a bug with the option or anything per chance? Since it actually goes to the screen where it asks for your password, then after that it doesn't care for it for that one minute it's set to... well at least now I have it on immediately which works.

Share This Page