Getting ready for 5.1

andy2141

macrumors 6502
Original poster
May 29, 2010
342
228
UK
Given it's highly likely we'll see 5.1 released along with the iPad 3 later this week, how are we fixed for 5.1 and downgrading to 5.0.1 should the need arise.

Last time I looked having blobs saved was useless and there was no restore path back to 5.0.1 once Apple has stopped signing it. Is this still the case, and I will now need to be extra careful about installing new stuff going forward?
 

negativzero

macrumors 6502a
Jul 19, 2011
564
50
Whatever the case, be extra careful when adding plugins cus you're royally screwed if you are forced to restore.
 

labman

macrumors 604
Jun 9, 2009
7,776
1
Mich near Detroit
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

Save shsh blobs for now just because. And wait to here from the dev-team or chronic before updating to 5.1 or else you'll be telling people you accidentally upgraded to 5.1 (embarrassing)
 

brsboarder

macrumors 6502a
Feb 16, 2004
750
13
more than likely anyone with a 4s will be screwed if they need to restore for awhile as the dev teams probably won't jb the ipad until the next iphone comes out.

Hopefully they figure out the way to use blobs on the 4s and allow restores/downgrades soon!
 

Cortezbanks

macrumors 6502
Sep 5, 2008
363
0
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Use redsn0w stitch blob feature(I believe that's what it's called). It creates a custom fw where your 5.0.1 blobs are saved in the custom fw
 

gotluck

macrumors 603
Dec 8, 2011
5,663
1,016
East Central Florida
you have a 4s or a 4? afaik a 4 can be restored using stitched blobs /w the apticket post 5.0.1

please correct me if I'm wrong. I thought my 4 had a safety net :p
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,652
6,404
At the iPhone hacks section.
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Use redsn0w stitch blob feature(I believe that's what it's called). It creates a custom fw where your 5.0.1 blobs are saved in the custom fw
That doesn't work with the 4S.
Just i4 and 3GS.
I'm looking forward to all the accidentally update threads:D
 

toasty hoodie

macrumors 6502
Sep 16, 2011
259
0
I'll probably update my iPad 1, but my iPhone is sticking with 5.0.1 until the next major version.
 

PhazeII

macrumors member
Dec 27, 2011
85
0
Southern California
What plugings are we talking about that could make your saved SHSH blobs useless. Thought this blobs with the Custom IPSW "signed" was good enough in case something went wrong.
 

andy2141

macrumors 6502
Original poster
May 29, 2010
342
228
UK
I don't think any of us that know a few things would accidentally update:)
But if something goes wrong on my 4S and I'm stuck restoring I'm sol.
This is my main concern. Not accidentally hitting upgrade, waiting for the download to complete and then applying it.

Time to get my 4S set exactly how I'd like it and not go playing in Cydia for a while until a method of restoring to 5.0.1 is found.
 

nanogirl21

macrumors 6502a
Sep 20, 2011
698
63
Midwest United States
I am not sure what shsh and blobs are but why wouldn't someone want to JB to the newest firmware IF there is a JB method for it? What do you guys mean be careful adding plugins? Are you talking about apps from cydia? How could adding them when the new firmware comes out any more dangerous than adding them now? Also, someone said that 4s users are basically out of luck. Why is that?
 

iToNe24

macrumors regular
Oct 3, 2011
222
7
NY
i used tinyumbrella to backup my iphone 4s ... but not sure if that will help much ... i hope 5.1 gets JB ... needs to be able to restore device after i mess it up ... haha

i will have to be very adamint with my backups until then