Getting rid of an adware virus

LesToil

macrumors newbie
Original poster
Dec 22, 2014
3
0
I thought I was updating my FLV player on my iMac today but I guess I grabbed myself a virus. It made YAHOO my search engines on both Firefox and Safari. I used Adware Medic and that solved the problem for Firefox and I was able to switch it back to Google as my default search engine, but Safari won't budge one inch from getting rid of YAHOO as my search engine--even though it says in Safari preferences the homepage is Google!

I then downloaded Avast and that's presently running a scan. If nothing positive comes from that, does anyone have any suggestions? I cleaned out my Safari history and cache and rebooted numerous times but nothing has changed.

Any help you can share would be greatly appreciated.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
You don't have a virus. Macs are not immune to malware, but no true viruses exist in the wild that can run on Mac OS X, and there never have been any since it was released over 12 years ago. The only malware in the wild that can affect Mac OS X is a handful of trojans, which can be easily avoided by practicing safe computing (see below). 3rd party antivirus apps are not necessary to keep a Mac malware-free, as long as a user practices safe computing, as described in the following link.
Read the What security steps should I take? section of the Mac Virus/Malware FAQ for tips on practicing safe computing.

Remove unwanted adware that displays pop-up ads and graphics on your Mac
Adware can be removed by using this tool: AdwareMedic
  1. Open Safari and reset it, clearing all cache and cookies.
  2. Close all apps.
  3. Run AdwareMedic.
  4. Reboot.
  5. Then open Safari and reset your home page.
Also, you can check the following locations for apps that automatically launch on startup and delete any you don't need/want:
  • System Preferences > Users & Groups > yourusername > Login Items (SL and older: System Preferences > Accounts > yourusername > Login Items)
  • In Finder, click Go > Go to Folder > /Library/LaunchAgents
  • In Finder, click Go > Go to Folder > ~/Library/LaunchAgents
  • In Finder, click Go > Go to Folder > /Library/StartupItems
Once you've removed the app from the startup list, restart your Mac.
 

yjchua95

macrumors 604
Apr 23, 2011
6,725
230
GVA, KUL, MEL (current), ZQN
I thought I was updating my FLV player on my iMac today but I guess I grabbed myself a virus. It made YAHOO my search engines on both Firefox and Safari. I used Adware Medic and that solved the problem for Firefox and I was able to switch it back to Google as my default search engine, but Safari won't budge one inch from getting rid of YAHOO as my search engine--even though it says in Safari preferences the homepage is Google!

I then downloaded Avast and that's presently running a scan. If nothing positive comes from that, does anyone have any suggestions? I cleaned out my Safari history and cache and rebooted numerous times but nothing has changed.

Any help you can share would be greatly appreciated.
You need AdwareMedic.
 

redheeler

macrumors 604
Oct 17, 2014
7,408
6,974
You need AdwareMedic.
Umm...

I thought I was updating my FLV player on my iMac today but I guess I grabbed myself a virus. It made YAHOO my search engines on both Firefox and Safari. I used Adware Medic and that solved the problem for Firefox and I was able to switch it back to Google as my default search engine, but Safari won't budge one inch from getting rid of YAHOO as my search engine--even though it says in Safari preferences the homepage is Google!

I then downloaded Avast and that's presently running a scan. If nothing positive comes from that, does anyone have any suggestions? I cleaned out my Safari history and cache and rebooted numerous times but nothing has changed.

Any help you can share would be greatly appreciated.
 

IHelpId10t5

macrumors 6502
Nov 28, 2014
477
314
You may not have a problem at all. Note that Safari's homepage preference is not what determine's the default search provider. Go to Safari's Preferences > Search tab > and set it to something other than Yahoo.