Getting SBCGlobal email to work as it did on my WM6 device

Discussion in 'iPhone Tips, Help and Troubleshooting' started by bluenoise, Jul 17, 2008.

  1. bluenoise macrumors 6502a

    Jul 16, 2008
    I'm a new iPhone 3G user and I'm trying to get it set up to my liking. Previously, I used a Moto Q9h with Windows Mobile 6. My problem is getting the email set up to behave as it did with my Moto. Here's what I want to have happen:

    1. When I view my email on my computer, I use the Yahoo "web 2.0" mail webapp and it works great. If I read, delete, or file a message there, the phone's email client is automatically updated to reflect this. It's not "push" but the regularly-scheduled fetch makes the message on the phone either look "read," filed in a folder, or gone (deleted). Likewise, reading or deleting a message on the phone causes a similar update on the web view. The phone also sees all the subfolders in my in-box. They behave as two clients viewing the same collection of email messages.

    2. On my iPhone, updating the status of a message on the server has no effect on the iPhone's in-box. If I delete a message from my web client, it's still sitting in my iPhone's in-box as unread. I have to delete it there separately. It's doing exactly the thing that makes me not use stand-alone email applications on my computer.

    A bit of Googling tells me I might get what I'm seeking by using IMAP instead of POP to read my mail. I 'stole' the settings from my Moto and modified my account settings in my iPhone to match, but now it's more jacked up. The iPhone shows I have five unread messages, but the in-box appears empty.

    I assume it is capable to doing anything my crappy Moto could do, so what's the trick for getting it to work as I want?

  2. operator207 macrumors 6502

    Jul 24, 2007
    Yes, IMAP is what your looking for.
    I have a separate email address for my iPhone (1st version, 1.1.3 firmware).
    I just used webmail to check email for that account. The iPhone had 8 emails total, and I delete 3 of them via webmail. They were showing in the iPhone and obviously showing in webmail. I deleted the 3 emails, then logged out of webmail. (the logging out may be what actually deleted the emails, not sure how the webmail actually deletes email, in realtime or when you logout) I then went to my iPhone, opened email, and it started to refresh. The 3 emails I deleted in webmail went away.

    If your wondering, I have my main account, and everything goes to that. I check it via an SSH tunnel from my laptop to the server with an IMAP client (Mutt and recently Thunderbird) This is for security purposes. Not that I get emails that are that important, but I am constantly on open networks, or nonsecure networks, and do not want someone reading my emails. (SSL and TLS is sometimes blocked at some of the locations I visit. No clue why though.) However, I want to get emails from my wife telling me to pick up the kids on my iPhone. So on the server, I have filters setup to forward emails from certain people to my iPhone. The iPhone is the only thing that checks that email address.

    I have my iPhone setup for a standard IMAP account, nothing special. Its essentially the default setup for IMAP as far as I know. Checks every 15 minutes.

    I hope this helps some. I do control my IMAP server, and there is the possibility IDLE is not setup on SBC's IMAP server.

    You can check by opening (HDD/Applications/Utilities/ or if on windows: Start -> run -> type cmd, hit enter:

    Type (on either): telnet imap.server.address 143 (hit enter)
    If you can do this it should give you something like this:
    >telnet 143
    Connected to
    Escape character is '^]'.
    Check for IDLE, this is the only piece I can think of that, if not present, would make IMAP a glorified POP.
  3. bluenoise thread starter macrumors 6502a

    Jul 16, 2008
    I got it working. I told it to set up a Yahoo account and then I adjusted some of the settings from there. I thought I had already tried that, but apparently I messed it up. It's working perfectly now.

Share This Page