Getting self-assigned ip address from Comcast modem

Discussion in 'macOS' started by brainwave89, Jun 18, 2008.

  1. brainwave89 macrumors 6502

    Jul 7, 2006
    When I hook up an ethernet connection from my Comcast modem to my Mac Pro and PowerBook G4 I end up getting an self-assigned ip address (169.254.x.x). When I hook up an ethernet connection to my Dell Dimension desktop from the cable modem I have no problem getting online.
    I have shut off the modem at various times from 30 seconds to 4 minutes before I plugged it back in with the same result on the Macs.
    I would love to hook up my Airport Extreme to the cable modem but I would be happy just to get this resolved first.

    Once or twice I was able to get an 192.168.x.x ip address on the mac's before it switched to 169.254.x.x.
    Any suggestions to get this resolved would be appreciated.
    Thanks for looking.
  2. NH MacGuy macrumors newbie

    Sep 29, 2007
    New Hampshire
    This also happened to me...

    on my Powerbook G4, running 10.5.3 Here is what ultimately worked...

    Unplug computer from modem
    Restart computer
    Open System Preferences, choose Security, then select the firewall tab.
    Select "Allow all incoming connections" & Close system preferences.

    Now, connect your Mac to the network (either wirelessly or via ethernet)

    Hopefully it will now receive a router-assigend ip. Once connected, I would go back to System Preferences & select a safer level of firewall security.

    I was prompted to try this after reading somewhere that this was a Leopard/Firewall bug.

    Hope this helps.

  3. brainwave89 thread starter macrumors 6502

    Jul 7, 2006
    Thanks for your help.

    The firewall setting is set to "Allow all incoming connections" already. The Mac Pro is running 10.5.0 and my PowerBook G4 is running 10.5.3.
  4. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    Can you clarify exactly how your devices are hooked up, starting from the modem? What are your network settings on the Macs?

    It should be something like this: Modem -> Airport router -> your computers. The router will be assigned an external IP from the modem. The computers will be assigned a local IP from the router. I don't see how with this setup your Macs would be configuring themselves with anything but the IP given from the router.

    The OS X firewall shouldn't have anything to do with it.
  5. brainwave89 thread starter macrumors 6502

    Jul 7, 2006
    Thank you apfhex.

    An Ethernet cable is coming from the Linksys Cable modem and was hooked up directly to both of the Macs at different times.
    In System Preferences > Network the built-in Ethernet has the following settings on both computers:
    Location: Automatic
    Configure: Using DHCP

    The PowerBook G4 had never previously attempted to get online with the Linksys Cable Modem. The Mac Pro had.

    Please let me know if I missed any pertinent information.
  6. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    1. Did the router run out of IP addresses to give out? Make sure you don't have your address range set to something like though

    2. Do you have any MAC filtering on?
  7. operator207 macrumors 6502

    Jul 24, 2007
    MAC address filtering done on the Comcast end of your connection. It will allow X MAC addresses from an account, X+1 will not work and so on.

    If X = 5, you can have 5 devices on their network, after that you have to call them and either have them delete old MAC Addresses, or have them delete all of them, and start over.

    They used to allow only 1 unless you called them and asked for more. That is one of the reasons every soho home router has "MAC address spoofing".

    I would bet if you called and talked to a knowledgeable Comcast tech, you could get them to tell you if your full up on MAC addresses.
  8. brainwave89 thread starter macrumors 6502

    Jul 7, 2006
    Thank you operator207. I will contact Comcast tomorrow.

Share This Page