Getting the 'sim lock' message all the time!

Discussion in 'iPhone' started by Hudzilla, Feb 20, 2008.

  1. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #1
    Ive done a search but couldnt find anything,

    I keep getting the sim lock message all the time when browsing safari, then i have to enter the unlock code to get back into my phone, ive tried a hard restore & a quick restore, but no luck.

    Is anyone else having this problem?

    Thanks.
     
  2. Flying Dutchman macrumors regular

    Joined:
    Oct 22, 2007
    #2
    How did you unlock it? What app did you use, are you using the original sim, some more info would help
     
  3. Hudzilla thread starter macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #3
    Its an original o2 phone, not jailbroken/unlocked.

    The sim lock I mean is the one when you first switch the phone on and it asks you for a unlock code

    Cheers
     
  4. Manj27 macrumors member

    Joined:
    Jul 10, 2007
    Location:
    London
    #4
    ^ I too get that every now and then (running legit o2 contract on 1.1.3 firmware) - havn't managed to find out why it does that, but can only re-enter unlock code to get Service again.
     
  5. Hudzilla thread starter macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #5
    Yea, it isnt a critical problem, just irritating!!
     
  6. pake macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    Delft
    #6
    Just disable the Sim lock and if you need use the passcode lock instead. You should be able to find it within settings>phone>sim... Its called PIN
     

Share This Page