Getting through process to unlock mac with apple watch SUCKED

Discussion in 'Apple Watch' started by thadoggfather, Oct 23, 2016.

  1. thadoggfather, Oct 23, 2016
    Last edited: Oct 23, 2016

    thadoggfather macrumors G3

    thadoggfather

    Joined:
    Oct 1, 2007
    #1
    in the end, unlocks super fast but between setting up 2FA (my fault I suppose, long in the tooth to do but there was an absurd grace period between wanting to enable 2FA and waiting before I was able to) but syncing between iPhone and mac, ironically there is no install process piece from the watch itself haha aside from it being the tool that unlocks your mac,

    had to reboot all devices to have it show up in system preferences too, but the 9to5mac Jeff Benjamin tutorial walked me through absolute hell.

    they could do way better, come on apple! it reminds me of apple tv4 set up without remote app on iphone at launch a major oversight like wondering if any apple tv engineers actually used it themselves, and one horizontal line to smack letters between to get all the app accounts on there. went from really excited to frustrated in no time,

    half baked implementation but once its set up, its friggin sweet!

    i wasn't even sure which sub forum to complain about this in, but apple watch being the involved element i figure whatever,

    this is the perfect example of why Apple's UX has deteriorated over the years, this is a prohibitive set up process!
     
  2. jerry16 macrumors regular

    jerry16

    Joined:
    Sep 12, 2016
    Location:
    across the universe
    #2
    This feature is definitely interesting. Once it is setup and working, it's fantastic - a huge benefit of an Apple Watch, IMO.

    It's getting there that is crazy. My girlfriend's Mac took 1+ hour to set up - my MacBook set up exactly and quickly as intended.

    Not sure why there is such a large discrepancy for so many people, but I do know Apple could and should do better. The average user isn't going to screw with it and scour Google for an hour plus trying to get it to work like I did - they'll just give up.

    It just works.. most of the time.
     
  3. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #3
    I set up several Macs for this. Went flawlessly.
     
  4. BorderingOn macrumors 6502

    Joined:
    Jun 12, 2016
    Location:
    BaseCamp Pro
    #4
    Yea, mine showed the option but told me to go setup 2FA and closed. Ok, how? When I looked, there was no option for it. I remembered reading somewhere that you might have to turn off two step. Ok, now I can setup 2FA, but the unlock with watch option is now gone from my Mac. So I reboot and it comes back. Everything works fine now but I agree it could have been easier, better guided, and more straightforward.
     
  5. irod87 macrumors regular

    Joined:
    Jan 25, 2012
    #5
    Setup was super quick for me. I remember no troubles.
     
  6. testcard macrumors 68030

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #6
    I originally followed the 9to5Mac tutorial, set up 2FA, and much to my surprise it worked. It's continued to work through several Sierra public betas. I agree that Apple needs to take another look at how unlock is implemented and get it working for everyone.
     
  7. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #7
    I still haven't succeeded. I got caught in 2FA hell. Turn off, turn on, turn on, turn off. Bah.
     
  8. ulinerg macrumors regular

    ulinerg

    Joined:
    Oct 21, 2014
    Location:
    Ottawa, Canada
    #8
    I agree. It was a bit of a pain. Turn 2FA off and on again and it finally worked. The other area I had trouble with was logging on to my Apple TV, I now need the iTunes password as well as the 2FA code on the same entry line with no space between the two. Took me a few tries to figure that out.

    Once it is set up it's great.

    My problem now is that I sold my Series 0 watch two weeks ago and I am waiting for a new one any day now.
     
  9. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
  10. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #10
    I think it proves that just because something can be done, does not mean it should be.
     

Share This Page