Getting trackpad to ignore touches while typing

Discussion in 'MacBook Pro' started by TitanTiger, Jan 30, 2018.

  1. TitanTiger macrumors 6502

    Joined:
    Jun 8, 2009
    #1
    Does anyone have a good solution to this problem other than turning off Tap to Click altogether? I really like Tap to Click but it's driving me crazy when I'm trying to type how often an inadvertent touch causes the cursor to move elsewhere in the document or sometimes even click outside of the current application altogether. I thought this used to be one of the ways that Apple's touchpad tech was superior to Windows laptops but I see tons of complaints about it online.

    I don't want to stick cardboard over the touchpad either. I've tried using Better Touch Tool but that doesn't seem to help unless I'm somehow not using it right.

    Anyone found a solution that actually works?

    My MacBook Pro is a 13" late 2013 model.
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    External keyboard if at a desk. Learn not to touch it if standalone.
     
  3. redleg6 macrumors newbie

    Joined:
    Jan 9, 2018
    Location:
    South Central PA
    #3
    To bad we can't program a fn key. or other key to disable the touchpad when using a mouse etc. My last laptop had that.
     
  4. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #4
    Actually you can do that if you go to System Preferences > Accessibility > Mouse & Trackpad. Click the checkbox next to "Ignore built-in trackpad when mouse or wireless trackpad is present."

    But I don't use a mouse normally. I just want the trackpad to ignore input when I'm typing. If it had a 1-2 second delay after the last keystroke before "tap to click" would work, that would be great.
     
  5. redleg6 macrumors newbie

    Joined:
    Jan 9, 2018
    Location:
    South Central PA
    #5
    Gee, thanks for the response/information. I'm brand new to MBP but learning everyday thanks to folks like you.
     
  6. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #6
    Well at least someone's problem got solved! :)
     
  7. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #7
    You can only do this in OS X by turning off tap to click, you may want to check out the better touch tool app this gives you far more control over the trackpad and touchbar.
     
  8. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #8
    Yeah, I've tried that and it doesn't seem to help much.
     
  9. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #9
    Making the trackpad so large that it "inputs" from the touch of people's palms while typing was really "progress", wasn't it...?

    No such problems on my 2015 MBPro... ;)
     
  10. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #10
    By all reports palm rejection is excellent it seems to be trailing fingers causing the issue.
     
  11. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #11
    My fingers aren't long enough to type and have the rest of them curl under and touch the trackpad.
    --- Post Merged, Feb 1, 2018 ---
    Doesn't the 2015 have the same size trackpad as the 2013 one?
     
  12. aevan macrumors 68030

    aevan

    Joined:
    Feb 5, 2015
    Location:
    Serbia
    #12
    I used the 2014 version for a few weeks while my MBP was away at service and while trackpad is good, it definitely feels cramped. Especially using gestures in Photoshop. Yes, the new trackpad is definitely progress. Much better.
    --- Post Merged, Feb 2, 2018 ---
    Turning off tap to click helps, but really no better solution than typing without resting palms anywhere. Rest your arms instead and hover with your palms above. It's not only great for avoiding accidental touches, it is also healthier for your wrists. It's the proper way to type, really.

    [​IMG]
     
  13. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #13
    While I appreciate the ergonomics aspect of what you're saying, the fact is, sometimes your hands do drop a little or sometimes you're holding the MBP in your lap where the proper technique isn't easy to pull off. All I'm saying is, the trackpad ought to be able to ignore incidental touches better than it currently does without having to give up the Tap to Click functionality.
     
  14. colinwil macrumors regular

    Joined:
    Nov 15, 2010
    Location:
    Reading, UK
    #14
    As a comprimise I turned off Tap to click, but set the 'Click' to Lightest possible. That works fine for me
     

Share This Page