Gevey invalid sim problem

itzkevino

macrumors newbie
Original poster
Jun 3, 2012
2
0
I have an iPhone 4 running on iOS 5.1.1 with a preserved baseband of 04.10.01 and a gevey sim. My phone ran out of battery yesterday and then I tried to do the unlock for tmobile but it didnt work. When I turned off the iphone then turned it back on, i waited for the welcome screen then hit cancel. i went into settings>phone>sim applications>english and then hit accept. i then dialed 112 15 seconds later and ended the call within 2 seconds. i turned airplane mode on until it said "no sim card installed" and then i turned it off. the message popped up sim failure and then my connection bars went up to 5 but it did not show the tmobile carrier. about 30 seconds later, it went down the 1 bar and then at the top it says invalid sim. please help me! i tried restoring but that didnt work :confused:
 

Minhimalism

macrumors 6502a
Jan 6, 2012
997
141
Texas
After you get the "No SIM Card Installed" message, try turning airplane mode on AGAIN right away for about 45 seconds after you turn it off, instead of waiting for the signal to come through. Try this and let me know how it goes.
 

Erikasmt

macrumors newbie
Jun 14, 2012
3
0
Actually I tried what minhimalism* said a few times and it ended up working. Thank you!

My Internet doesn't want to work, what are the network settings? I tried one but didn't work
 

slantdawg

macrumors newbie
Jun 13, 2012
4
0
When I run into issues like this, i find that I have to sometimes reboot my phone and if that does not work, I remove the SIM card and reinsert it with the phone on.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.