gevey sim only works once

Discussion in 'Jailbreaks and iOS Hacks' started by macmac80210, Apr 22, 2011.

  1. macmac80210 macrumors newbie

    Joined:
    Apr 22, 2011
    #1
    Hello! I bought a gevey sim and when I try to use it on my iphone 4, it doesnt work UNLESS I restore to a factory firmware, then it will work once until you reboot it. By not working, I mean it goes through all of the steps but when it goes to connect to the network after the no sim card installed message, it gets bars but never says "T-Mobile' then after about 30 seconds of this, it just says "no sim installed" then "sim failure". This is my second gevey sim, and my first one was doing the same thing! I have no idea what I am doing wrong. During the 30 seconds where it does have bars it shows the little "E" for edge but then it just quits. I can also call and get calls during that time but when it shows the "sim failure" the calls just fail.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Did you turn off 3G in settings?
    That might be causing issues cause the iphone is not compatible with Tmobile USA 3G bands.
     
  3. macmac80210 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #3
    Ya I do. As I said, it works after I restore, but when I reboot and try to unlock again, it doesnt work until I restore it again...

    but thanks!
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    That sucks bro, did you purchase the gevey from a reputable source to make sure its not a knockoff that doesnt function properly?
    You said this is the 2nd one you got from the same place? Maybe return it and get your money back and purchase from another seller.
    It seems to work fine for everyone else.
     
  5. macmac80210 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #5

    I purchased it from gevey-3g.com? They have already replaced it. I heard that It might be my sim....haha might also be my phone. Really weird problem huh? I mean I just wonder why I have to restore it every single time. Haha thanks for your help bro.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    No doubt, weird for sure.
    Have Tmobile replace your simcard to see if that fixes it or not.
     
  7. hiinhoc macrumors member

    Joined:
    Sep 1, 2010
    #7
    can we unlock iphone 4 without Gevey sim on the latest fw 4.3.2?
     
  8. chiefpavvy macrumors 6502a

    Joined:
    Feb 23, 2008
    #8
    If your baseband is beyond 1.59.00, no.
     
  9. PhxF macrumors newbie

    Joined:
    Apr 6, 2011
    #9
    Did you turn your phone off and then insert it, and then turn it on?
     
  10. Zermelo macrumors regular

    Joined:
    Nov 18, 2010
    #10
    Try reseating the sim card and making sure that the contacts have proper connections, I had an issue seating the sim card correctly and it wouldn't work until I reseated it and ensured the contacts were making proper connection.
     
  11. Vizzard macrumors newbie

    Joined:
    Jun 12, 2011
    #11
    Same thing is happening to me

    Exact same thing happens to me. I did different troubleshooting and it looks like is the sim that is the one not working. Using Firmware 4.3.3 BB 4.10.1 with Gevey Sim Pro

    1. Tried a simple mobile sim with the gevey more than once. Works
    2. Tried on two different phones the step above more than once. Works
    3. Restored the firmware. Works only the first time(t-mobile sim), after reboot device can't get signal again. Restored again, works only the first time
    4. Tried without jailbreak step 1 and 2. Same problem as step 3
    5. Reset Network Settings. Did not work
    6. Got a new sim card from t-mobile, same problem as step 3.
    7. Downloaded ultrasn0w. Didn't help.
    8. Called t-mobile asked them to reset the sim signal. Worked!!! for 1 1/2 day(lost signal)
    9. Called them again. This time didn't work.
    10. Installed Carrier Rest Fix. Did not work.
    11. Tried many other troubleshooting options from youtube/websites
    12. I NEED TO SWITCH TO SIMPLE MOBILE :mad:
     
  12. Vizzard, Jun 14, 2011
    Last edited: Jun 14, 2011

    Vizzard macrumors newbie

    Joined:
    Jun 12, 2011
    #12
    I think i got the solution

    The only thing that worked for me was going into Settings > Carrier (this should be available after you exit airplane mode, on your first trial of the gevey sim after it fails to connect.) > inside carrier you should let it search network, t-mobile and At&t should come out as an option(might take sometime but just be patient) at this point you should choose t-mobile as your option (DO NOT LEAVE IT AUTOMATIC). Make sure to have wifi, edge, and 3g off. Turn off your phone (wait around 10-15 secs > turn it back on, the gevey welcome screen should come out > Accept > new message with appear: Message-Carrier chosen is not longer available (Just press Dismiss or let it disappear. DO NOTHING at this point but keep going with the usual procedure; call 112 after first bar comes out; hand up after 2 secs, go back into settings (make sure that your 3g,edge,wifi is off, because on sbsettings sometimes I had 3g on for some strange reason); turn on airplane mode; after sim card message comes out turn plane mode off > next two warning message will come out (after the last one disappears) > then go to carrier in settings and make sure the Automatic option is not chosen (if it is, you probably did something wrong); the bar should not go up like before is going to stay in 1 bar but all of the sudden BOOM you get signal with t-mobile(be patient).

    This works on Firmware 4.3.3 BB 4.10.1 and jailbroken(with redsn0w)
    ****!!!! TOOK ME A Week of troubleshooting to find this out.

    GOOD LUCK!!!:p
     
  13. ratzzo macrumors 6502a

    ratzzo

    Joined:
    Apr 20, 2011
    Location:
    Madrid
    #13
    Thanks for your feedback, Vizzard.

    To the OP: the original Gevey website is applenberry.com, I'm not sure about gevey-3g. Apparently, the 'PRO' version deals with plenty stability issues as well. Most carriers can swap and replace your SIM card for free at any of their authorized retails, there are loads of them so one should probably be near you.. it wouldn't hurt to try!
     
  14. Nibas macrumors newbie

    Joined:
    May 25, 2011
    #14
    Solution?

    Hey,

    I was having the same problem thinking that the gevey sim only worked once. I was actually forced into restoring my phone like 3 times as well.

    What my problem was is that even thought he gevey accept screen came up right when I turned on the phone, the procedure wouldn't work...

    OR!!! the screen wouldn't come up at all...sooooooo

    Then I was like...WTH - let's try this. So i tried a couple of things...

    What ended up working for me was...

    Settings - airplane mode ON - pop up no sim installed, OK - remove sim - insert sim - airplane mode OFF.

    Then I was given 1 status bar, searching, and then gevey sim instructions and accept menu popped up again :) Procedure worked this time as indicated on the accept menu.

    Have tried it a few times since then. Works well.

    Cheers
     
  15. Heartytan macrumors newbie

    Joined:
    Aug 20, 2011
    #15
    this actually worked for me.
     
  16. topspinner macrumors newbie

    Joined:
    Sep 10, 2011
    #16
    Finally The Best Solution I ve Found

    http://www.youtube.com/watch?v=6QxpBXmwMT8&feature=related

    I think this is the best solution for GeveySim either original or not
    1 - first shutdown 3G and Data
    2- Activate SIM pin
    3- Reboot
    4- Enter PIN LOCK and continue to press OK many times until sim unlock Success appears
    5- THE GEVEY Message will appear shortly after
    6- do the 112 and the Airplain On/Off till SIM LOCKED message appear
    7- enter the PIN number and press OK ONCE (((( ONLY ONE TIME ))))
    8- Enjoy Your Unlocked Iphone

    Thanks 4 You All
     

Share This Page