Gevey Ultra Sim w/ T-mobile Prepaid - Not Working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by yemididit, Mar 8, 2012.

  1. yemididit macrumors newbie

    Joined:
    Mar 8, 2012
    #1
    Hey Folks,
    New to the forum and of course i have a desperate situation:

    I have a iphone 4 jailbroken running iOS5 on BB 3.10.01. I have a gevey ultra sim and my service is t-mobile prepaid.

    I put the sim in while powered off. Turn it on and out of the gate, the problem is there's no gevey welcome screen message & it says there's NO SIM INSTALLED.

    So i decide to go to setting>phone>sim options?>and select the language to prompt the welcome so i can accept but i can't do that because "phone" option is grayed out and its saying NO SIM.

    What can i do? Does tmobile prepaid not work with Gevey Sims? Is there something I'm missing?
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  3. yemididit thread starter macrumors newbie

    Joined:
    Mar 8, 2012
    #3

    We tested it with another sim and it worked (calls/data/and all) without the furious mod. When i tried mine and after a lot of failed attempts, I installed the furious mod and it didn't work either. i then uninstalled it.

    Should i put it back in the mix?
     
  4. yemididit thread starter macrumors newbie

    Joined:
    Mar 8, 2012
    #4
    Ok so the happy ending to this story for anyone who may be dealing with this now:

    Went to the T-mobile store and asked for a pre-cut sim card. Apparently the normal sim cards that they hand out and cut right there weren't working with my Gevey. So i go to the T-Mobile store AGAIN (a different one) and ask for an official micro sim (one that was made that way).

    As soon as i put it in & restarted the phone, the gevey software welcome screen came up (already a good sign) and i could start the process properly.

    It definitely took me an entire day of trying to finally get the temperamental gevey process to work but i finally got and I'm loving my phone.

    Cant wait for an easier software unlock for this but it's working and its all good.
     
  5. dglenn9000 macrumors member

    Joined:
    Sep 23, 2007
    #5
    Maybe thats what is wrong with my phone too. I have been battling with he gevey ultra for a month now. It worked for first 6 months straight then I had my screen replaced and when the guy gave me back my phone the gevey was acting up. I though it was something he did but then I got it to work for a week after that but it has not worked since. Maybe it is the sim card I cut myself. I will try the tmobile micro sim. Hope it doesnt cost much.
     

Share This Page