gfxCardStatus bugs?

Discussion in 'MacBook Pro' started by playsontheleft, Sep 2, 2012.

  1. playsontheleft macrumors regular

    Joined:
    Jul 2, 2012
    #1
    I've heard from some users here that gfxCardStatus on the 2012 MBP and rMBP is causing some serious issues. I've noticed some odd behaviour on occasion in my rMBP, usually involving a black screen which is hard to get out of upon waking from sleep, and I'm wondering if this may be attributed to gfxCardStatus. What issues are you guys experiencing with it and what alternatives are you using?
     
  2. dw3bb10 macrumors 6502

    Joined:
    Nov 1, 2008
    #2
    Im not experiencing any issues on my 2012 cMBP.
     
  3. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #3
    Same here no issues, so far gfxCardStatus is working as expected
     
  4. Engali macrumors member

    Joined:
    Jul 7, 2012
    #4

    I had that same problem. It would stay in black screen with the cursor visible and I would have to hit Esc to make it return to complete black screen and then wait a while to get it to wake to the password screen. This wouldn't happen if I waited a long time after closing the lid before opening it back up. All the MS office programs I installed would freeze up and not respond--I don't know if it was related.

    What fixed both issues is resetting the SMC. Look it up. You shut down your rMBP, press like three keys, and the turn it back on. I'm not pretending to know everything abiut this or to be an expert; just sharing what fixed my problem.
     
  5. Adidas Addict macrumors 65816

    Adidas Addict

    Joined:
    Sep 9, 2008
    Location:
    England
    #5
    No issues with gfxcard status v2.2.1 on my rMBP running OS X 10.8.1.
     
  6. charlieegan3 macrumors 68020

    charlieegan3

    Joined:
    Feb 16, 2012
    Location:
    U.K
    #6
    I sometimes have issues with it not always switching adapters on call as well is issues with the icon not being correct.
     
  7. Keinding macrumors newbie

    Joined:
    Jul 28, 2012
    #7
    same here.
     
  8. gwang73 macrumors 6502a

    gwang73

    Joined:
    Jun 14, 2009
    Location:
    San Francisco Area
    #8
    I don't have any issues with gfxcardstatus either running on rMBP with 10.8.1.
     
  9. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
  10. Psilocin macrumors member

    Joined:
    Jun 20, 2012
    #10
    Not sure if this is a bug or not, but the switching gets messed up if you shutdown/restart with the app set to integrated only. Can be fixed by putting it back to switching mode and restart again.

    Not a big problem, but just have to remember to change the setting before a shutdown.
     
  11. playsontheleft thread starter macrumors regular

    Joined:
    Jul 2, 2012
    #11
    Really? I'll try doing that and see if it still happens. If your suggestion works, which it sounds like it will, thank you very much in advance!
     
  12. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #12
    If I set my rMBP to Integrated only, and reboot; the computer will not go past the login screen. It will lock up with a blank screen, the other issue is I tend to a get black screen when waking up from sleep.

    To rectify these problems, I need to force a hard shutdown, reset the PRAM and try again.
     
  13. bitninja macrumors regular

    bitninja

    Joined:
    Jun 16, 2007
    Location:
    San Jose, CA, USA
    #13
    Power source-based switching is rather buggy in v2.2.1. I'm removing the feature outright from v2.3 due to the number of problems it's causing.

    Anyone that has experienced the "black screen at login" issue: have you upgraded to 10.8.1 or a developer seed of 10.8.2 and still had problems?
     
  14. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #14
    Neither am I on my rMBP :apple:
     
  15. charlieegan3 macrumors 68020

    charlieegan3

    Joined:
    Feb 16, 2012
    Location:
    U.K
    #15
    ha, nice to have the actual dev on here ;), issues aside it's a great app, i think the user base proves that. good job.
     
  16. bitninja macrumors regular

    bitninja

    Joined:
    Jun 16, 2007
    Location:
    San Jose, CA, USA
    #16
    Thanks :)
     
  17. kefaith macrumors member

    Joined:
    Feb 21, 2012
    #17
    I've been experiencing that since 10.8.0 and now I'm on 10.8.1 with issues still.
     
  18. stevelam macrumors 65816

    Joined:
    Nov 4, 2010
    #18
    i'm on 10.8.1 and have now experienced the black screen issue. so its definitely gfxcardstatus thats causing it?
     

Share This Page