Ghost file in Trash on External FAT32 Drive

Discussion in 'OS X Mountain Lion (10.8)' started by AndaM, Feb 14, 2013.

  1. AndaM macrumors newbie

    Dec 13, 2012
    Hi, I have tried many solutions on the web and did a lot of research on my specific problem but cannot find a working solution.

    It all started because the Trash always contains a folder and emptying the Trash would not delete it. The folder is on an external FAT32 drive and will only show when the drive is connected (normal behaviour).

    Since nothing worked to this point I decided to investigate further and here is the situation.

    When I browse to the .Trashes folder on the external drive in Terminal, I can see a file in the stuck folder when doing a ls -a. The ls command shows a file that does not show in Finder, even when I show hidden files and folders (I use Path Finder). When I then try to delete the file with rm I get "No such file or directory". Which is wierd as ls does show the file and I did not do a typo when typing the file name.

    So there is some sort of ghost file in there that is preventing me from deleting the folder and empty the trash.

    I have performed a Repair on the volume in Disk Utility with no success...

    Any ideas for me?


Share This Page