Gigabit Network woes

Discussion in 'macOS' started by SDAVE, Jul 25, 2007.

  1. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #1
    I have one Mac and one Windows machine connected directly together via a gigabit crossover cable. I grab files from the Windows machine from the Mac computer.

    Sometimes when the Windows machine is turned on before the Mac machine, the copy speeds are really slow. When I have the Mac machine on, and then the Windows machine on the speeds are very fast (~75-80MB/sec).

    At all times, both machines see the link speed as 1.0Gbps. I also use bootcamp to run XP on the Mac, and this causes my Macced XP to not grab files as fast as it should.

    Any ideas? Basically it is not a stable connection. Both computers have wireless connections. Do you guys think the "Internet Sharing" icon on the Windows box is causing this? I tried to delete it but I can't find a way to do it.
     
  2. zv470 macrumors 6502

    Joined:
    Jul 4, 2004
    Location:
    New Zealand
    #2
    Hi,

    Just cos you're connecting both machines via Gigabit Ethernet... doesn't mean you'll get 128MB/s.

    Transfer speed depends on the read/write speed of the hard drive on each machine on the network. Another thing that limits speed is the size of frames. Each file gets split into frames. A frame includes header information, checksum, etc... including a fraction of the data.

    One thing you can try is to make sure you've got both machines sending Jumbo Frames... which are the max size of 9000k... this way you're minimizing the number of frames that need to be sent... so minimizing all the extra data, ie: header, checksum etc... that needs to be sent.

    RE: the speed difference you're experiencing... I don't know if this would have any bearing but... I would turn the faster machine on first so that it can be the master, and then the slower machine the slave...? Does anyone know if that makes a difference? :eek:
     
  3. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #3
    I know drives make a difference here, that's why I've tested reading off multiple drives, and during my tests I've gotten a stable 75-80MB/sec, which is pretty damn good if you ask me. This just started happening to me, so...

    I forced both controllers to be on gigabit full duplex. I will try Jumbo frames to see if that makes a difference, because it doesn't go through a router/switch, I don't see how I could be limited by this.
     
  4. Angrist macrumors 6502

    Joined:
    Mar 11, 2005
    Location:
    MI or NJ
    #4
    They may be attempting to make a wireless connection instead of a wired connection.

    In Network Preferences, under the Port configurations screen, make sure that the ethernet connection is listed above the Airport connection.
     
  5. zv470 macrumors 6502

    Joined:
    Jul 4, 2004
    Location:
    New Zealand
    #5
    As a comparison... Lacie Gigabit Ethernet disks have these specs:

    Burst Ethernet Transfer Rate:

    In SMB up to 20MB/s (read), up to 11 MB/s (write)
    In SMB with Jumbo Frame: up to 44MB/s (read), up to 23MB/s (write)
     
  6. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #6
    I had that problem before, but now my ethernet is at 192.168.2.XXX and my wireless connections are all on 192.168.1.XXX

    If I put the ethernet on top of AirPort, it thinks that the ethernet has an internet connection so I can't even get online. I have assigned static IP's to both computers, I am not using a "router" IP, only an IP and Subnet Mask.

    I don't know just some freaky stuff is going on. Even under Windows with Bootcamp I have the same issue? I mean even if I get an expensive switch with jumbo frames, I think I will still get into such trouble.
     

Share This Page