Gigaware USB Headset not recognized by OS X

Discussion in 'Mac Basics and Help' started by Dj64Mk7, Jun 25, 2014.

  1. Dj64Mk7 macrumors 65816

    Joined:
    Sep 15, 2013
    #1
    I am trying to use my Gigaware USB headset to listen to audio on my Mac. The problem is that the headset is not recognized at all by OS X. I checked the System Profiler, and it isn't even recognized as a USB device. What should I do?
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    Brobdingnag
    #2
    Is this a new headset? Did it work before on your Mac and now it doesn't? Has it ever worked on a Mac?


    Possible solutions:
    1. Try the headset on some non-Mac computer to see if it works at all.

    2. See if the manufacturer has downloadable Mac drivers for your specific headset model. You didn't say what headset model, so no one else can do the search for you.

    2. If it the headset works on other computers, and there are no Mac drivers, and you need a headset for the Mac, then get a different headset not made by the same manufacturer.

    Personally, I would look for headsets that specifically say they work with OS X. Because sometimes they don't work, even when you think they will.
     
  3. Dj64Mk7 thread starter macrumors 65816

    Joined:
    Sep 15, 2013
    #3
    This is actually the only headset I had lying around, so I figured it was worth a shot. I remember it being recognized one by my Mac, which then had a kernel panic.

    1. I tried it on a Windows 8.1 PC, and it was recognized with a driver, but I couldn't figure out how to play audio through it.

    2. The brand is GigaWare. I can't find any support document or websites for the brand.

    I can't just go out and buy a new headset, as I'm completely broke. That's why I'm trying to see if this will work at all. Thanks for the help!
     

Share This Page