Gimp & X11 not working

Discussion in 'Design and Graphics' started by Bonzai, Jan 31, 2012.

  1. Bonzai, Jan 31, 2012
    Last edited: Jan 31, 2012

    Bonzai macrumors newbie

    Jan 31, 2012
    Hi all,
    Sorry to ask a question that I'm sure someone must know the answer to as I have been searching for answers all day, but to no avail.

    I have been trying to download Gimp, but each time I've done it, it just won't work.

    I have Apple X11 on my system, but I'm guessing it's not right somehow as I've read it needs to be the one from the install disk. However, I bought an iMac and it did not come with an install disk, everything was already preinstalled.

    Somebody out there must have come across this problem. Is there a solution without me having to go and buy a separate install disk? I have tried to find X11 online but the Quartz ones don't work with Gimp apparently and anyway I was forbidden access to the download by my server apparently...

    Any suggestions?

    - btw - when I open Gimp after installing, it opens the program and the icon shows in my dock but there are no options for me to do anything. And I have Mac OS X 10.6.8

  2. waloshin macrumors 68040

    Oct 9, 2008
    You have to click the X11 icon not the Gimp icon; clicking the X11 icon will bring up the menus for gimp.
  3. BillMidwest macrumors newbie

    May 25, 2011
    You’ll need to have both Apples X11 and Quartz X11 installed in Applications/Utilities to run GIMP and other non-Apple X11 applications. First install Apples X11 (I have Apples X11 2.6.3), then Quartz X11. Quartz X11 has a yellow ring around the letter X. When I was running 10.6.8, Quartz X11 2.6.3 would not open GIMP so I deleted it and re-installed Quartz X11 2.6.2 and had no problems on 10.6.8 and now 10.7.3.

    I’ve been using GIMP 2.6.10 without any issues on 10.6.8 and now 10.7.3, but starting it or any other non-Apple X11 app from Quartz X11 will try your patience. It can easily take 3 - 4 minutes for GIMP to open. It’s usually faster to open GIMP from Applications and Quartz X11 opens automatically; at least on 10.7.3. I plan on trying GIMP 2.6.12 and Quartz X11 2.7.0, the latest releases of both. If either doesn’t work I can back-off and re-install the versions I know work.
  4. Bonzai thread starter macrumors newbie

    Jan 31, 2012
    Hey guys thanks very much for the replies. I'll be trying these out tonight and hopefully have some success.
  5. AkronDex macrumors newbie

    Aug 5, 2012
    I had this same issue on my iMac, with GIMP and X11 both showing up in the dock when I open GIMP, but no UI options. I solved the problem by closing both programs, going into the utilities folder, opening up XQuartz directly, then closing XQuartz. When I then opened GIMP, it and XQuartz (instead of X11) showed in the dock and all of GIMP's UI appeared. I played around and made a few files so everything seems to be working.

    All of the above was done after doing the normal instructions for installing, including the restart after installing XQuartz.

    24" Imac, 10.6.8, 4 GB ram, 1.93 Ghz Intel Core 2 Duo

    Hope this helps. Probably a little late for the OP, others might find the solution with search.

Share This Page