Glibmm, Gtk, and Xcode

Discussion in 'Mac Programming' started by lilmeh, May 19, 2008.

  1. lilmeh macrumors newbie

    Joined:
    May 19, 2008
    #1
    hi guys,

    I'm tryin to build within xcode (by just pressing the build button) and although I have fink installed, I can't get it to compile with glibmm as well ("bugs" detected whereever glib is mentioned/linked within code).

    I'm new to Xcode although not new to C++, help would be greatly appreciated.
     
  2. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    You need to setup the paths for libraries and includes in your .profile file in your home directory. If you installed them with Fink then the paths you need to add are /sw/local/lib and /sw/local/include iirc.

    Also make sure to include the libraries in your project as well.
     
  3. lilmeh thread starter macrumors newbie

    Joined:
    May 19, 2008
    #3
    this is my .profile now:
    but it still doesn't work?

    I suck. :(
     
  4. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #4
    It should look something like this:

    bold lines are the ones you are interested in. Change them accordingly.
     
  5. lilmeh thread starter macrumors newbie

    Joined:
    May 19, 2008
    #5
    nope does it make a difference that I'm using Leopard and built fink from source?
     
  6. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #6
    Did you include the libraries in your Xcode project? What does your .profile file look like now? Make sure the paths are indeed correct, I don't have Fink on my system and had to do it from memory.
     
  7. lilmeh thread starter macrumors newbie

    Joined:
    May 19, 2008
    #7
    you mean the #include headers right? if yes, then yes, I have them but Xcode says "glibmm.hh not found" etc.

     
  8. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #8
    No I meant the libraries. Did you include the libraries in your project by going to the Edit Project Settings menu item (or similar)?

    Also as I said before make sure the paths in .profile are correct.
     
  9. lilmeh thread starter macrumors newbie

    Joined:
    May 19, 2008
    #9
    no sorry, I'm new to xcode so don't know how :(
     

Share This Page