Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502a
Original poster
Mar 4, 2022
United States
A few months ago, I was able to get some old macOS (OS X) versions to work on my M1 MacBook through UTM and emulating a PowerPC Processor. However, this no longer works. I am using the EXACT same settings I was using before, and now I am getting this error "Guest has not initialized display." I've tried 10.0 and 10.2 which I know for a fact work (because they worked before). I have physical 10.3 installer DVDs in a filing cabinet back home, so I can test those out next week also.

One possible reason I though of is because the ISOs are corrupted, but I highly doubt that. Am I missing something, or am I just doing it completely wrong? Screenshot attached.


  • UTM Glitch.png
    UTM Glitch.png
    682.3 KB · Views: 166


macrumors member
Jan 20, 2004
I'm getting the same problem when trying to create a PPC virutal mac for the first time. Same error message on a newer intel Mac.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.