Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Glitch on boot: anyone else?

Jutah

macrumors 6502
Original poster
Mar 30, 2012
379
105
Hi everybody, on my MBP 2019 it happens that - randomly - it glitches at boot. See image attach. I have Mojave updated to the very last release.

It happens only at boot, and not every time.

Pretty sure it's software related so i think it's not necessary to book an appointment.

Any suggestion? i did a pram reset, but it doen't work.
 

Attachments

  • mac.jpg
    mac.jpg
    92.1 KB · Views: 257

ptfuzi

macrumors member
Jan 9, 2019
58
14
It used to happen when logging in, but I had file vault disabled since then
 

Jutah

macrumors 6502
Original poster
Mar 30, 2012
379
105
any help please? i did a PRAM reset, a disk check at boot (all ok), and a new installation of Mojave (not "clean"). When i reset the PRAM, the glith show up at the reboot, and the for the rest of the day it doesn't appear anymore. May the SMC reset van help?
 

Jutah

macrumors 6502
Original poster
Mar 30, 2012
379
105
Looks like a firmware bug.
I would try a full 10.14.4 install to see whether it updates the firmware.

thanks to your answer.

I'm pretty new on the Mac so, what would I provide a full install 10.14.4? and then, am I supposed to setup all my settings again or may I use the time machine? probably the time machine back still replicate the error..
 

Glenvj

macrumors newbie
Aug 3, 2019
4
0
Hi Jutah, so is the glitch still happen or is it gone? I got the same glitch too with my MBP 19, and only happen when cold boot.

I am in mojave 10.14.6, and about to try to clean install my macbook.
 

Jutah

macrumors 6502
Original poster
Mar 30, 2012
379
105
Hi Jutah, so is the glitch still happen or is it gone? I got the same glitch too with my MBP 19, and only happen when cold boot.

I am in mojave 10.14.6, and about to try to clean install my macbook.
Hi Glenvj,
well, my MBP is not glitching since a while.

It seems that the 14.6 did something, not sure the glitch has gone for good.

If a was you I do not waste time in a clean install: in the vast majoriry of case nothing changed after that.

I will, instead, wait for Catalina to be released in a couple of month.

That major update should fix that annoying glitch once and for all :)
 

Glenvj

macrumors newbie
Aug 3, 2019
4
0
Hi Glenvj,
well, my MBP is not glitching since a while.

It seems that the 14.6 did something, not sure the glitch has gone for good.

If a was you I do not waste time in a clean install: in the vast majoriry of case nothing changed after that.

I will, instead, wait for Catalina to be released in a couple of month.

That major update should fix that annoying glitch once and for all :)

I did clean install on my Macbook yesterday, and the glitch is still there.
So I think I will wait for Catalina as you said.

I will just believe this is a software issue, and I hope it will gone just like yours too.
Thank you Jutah for your response. :)
 

Jutah

macrumors 6502
Original poster
Mar 30, 2012
379
105
I did clean install on my Macbook yesterday, and the glitch is still there.
So I think I will wait for Catalina as you said.

I will just believe this is a software issue, and I hope it will gone just like yours too.
Thank you Jutah for your response. :)

you're welcome :)

please let me know if with catalina the issue will go away!
 

Glenvj

macrumors newbie
Aug 3, 2019
4
0
For the update, finally the glitch is gone after I upgraded to Catalina 10.15.1. No more worry when booting up my macbook. Yay!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.