Glitch with the keyboard

Discussion in 'iPhone' started by timotheezz, Jul 30, 2007.

  1. timotheezz macrumors regular

    Joined:
    Jul 6, 2007
    Location:
    New Jersey
    #1
    I don't know what happened to my phone.

    It was fine for two weeks, then when I tried to respond to texts yesterday, I tap on the area to type on and it won't register.

    So I go back to the main menu of Texts, and I open up a new conversation with someone. That works. As I tried to write the text, I noticed I couldn't even press the spacebar. The numbers/symbols button wouldn't work. And neither would return. If I tried to click those buttons, it would only register the nearest button above. ArrRRRggh!

    So, I restored it. Like 5x, and still doesn't work.

    I restored it using iTunes, with that whole process of "restoring" I guess?

    Is there any OTHER way to restore the phone?

    My keyboard's not working properly.

    Also: same keyboard problems when trying to register a new email account, and when on safari. HOWEVER!, in landscape mode the keyboard works just fine.

    Also: I thought it might've been the area of the screen taht was no longer touch sensitive. But those areas work just fine in iPod, and Phone menus.

    Someone help?
     
  2. ejrizo macrumors 6502

    ejrizo

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles
    #2
    Clean your screen... maybe some gunk on their causing it
     
  3. timotheezz thread starter macrumors regular

    Joined:
    Jul 6, 2007
    Location:
    New Jersey
    #3
    Thanks just tried that. It's obviously a software issue, because when I slide to unlock, there's no problem (and that's on the bottom of the screen)

    But the last row of the keyboard just does not work. Arrgh.

    Any way to really really reset it? Other than "reset" ?

    Sounds ridiculous, I know. Just getting frustrated and desperate.
     
  4. earnjam macrumors 6502a

    earnjam

    Joined:
    Jun 7, 2007
    Location:
    North Carolina
    #4
    You can always take it to the Apple Store and show the guys at the genius bar. They might just replace it.

    If people are getting their's replaced for 1 dead pixel, then I think your case warrants a replace. Assuming you have done a full restore already.



    You didn't hack it did you?
     
  5. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #5
    The EXACT same thing happened to me, I could no longer register the bottom row keys and it would register the keys above. I tried hard reseting, restoring and nothing worked.

    Made an appointment with the genius bar and they replaced it with a new one with no problems. :)
     
  6. timotheezz thread starter macrumors regular

    Joined:
    Jul 6, 2007
    Location:
    New Jersey
    #6
    Thanks! Do I have to bring in everything? The box, cables, etc.? Or can I just bring in the phone? Also, the times available for the Genius Bar at my nearest store is too late in the afternoon. They accept walk-ins right?
     

Share This Page