Glitchy email inbox?

Discussion in 'iPhone' started by Pjstock42, Jun 30, 2010.

  1. Pjstock42 macrumors regular

    Joined:
    Jun 15, 2010
    #1
    I have the red circle with a 1 in it on my email icon, but when i go into my email the only "unread" things are these. i cant open them and i cant even swipe to delete them. Whats up with this?

    [​IMG]
     
  2. the-oz-man macrumors 6502

    the-oz-man

    Joined:
    Jun 24, 2009
    #2
    Having a similar issue with my wife's phone. Her email account is mobile me and usually a power cycle fixes this issue.
     
  3. babby macrumors member

    Joined:
    Jan 26, 2008
    #3
    Gmail?

    Are you using gmail? My gmail was buggy and was doing this. I set it up as an exchange account and seems to be working better now.
     
  4. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #4
    That kept happening to me and it finally stopped when I turned off threaded email viewing.
     
  5. thekjs88 macrumors member

    Joined:
    Oct 14, 2008
    #5
    i've had the same issue since i up graded to iOS 4.0 if i go to settings, mail, click gmail, and toggle mail from on to off and then back to on, it fixed it. hopefully this will be fixed soon? seems to happen pretty randomly.
     
  6. thekjs88 macrumors member

    Joined:
    Oct 14, 2008
    #6
    does it work like imap? if i do something to the inbox on my phone, will it show up in gmail?
     
  7. james92se macrumors 6502a

    Joined:
    Jun 21, 2010
    Location:
    Dallas, TX
    #7
    Odd. This used to happen to me all the time when I was using IzyMail for Hotmail, but it has never happened to me on any of my iPhones on Yahoo or Gmail
     
  8. the-oz-man macrumors 6502

    the-oz-man

    Joined:
    Jun 24, 2009
    #8
    Ugh, me too. IzyMail was a brief solution for me, but I hated it so much. I'm happy to pay Mobile Me now.
     
  9. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #9
    Slightly OT, but jeez those screenshots have gotten big!
    :D
     
  10. boxstboy macrumors member

    Joined:
    Jul 25, 2009
    #10
    This happens to me all the time now that I updated to iOS4. Going into and out of mail a few times fixes it, but I can't reply to the sender until it loads. Google on Mail.app really sucks IMO.

    What's with the Dec 31/69 date?
     
  11. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #11
    Mine isn't glitchy, but rather than start a new thread for a simple question, is there any freaking way to get the red delete button back rather than have archive be there? I hate this. I'm CONSTANTLY archiving emails that I mean to delete out of habit. I select multiple emails and then I hit archive because I'm used to it being the delete button.

    I do not like having to hit move -> and then trash. That makes no sense. Delete should be the easier option to get to, with move -> archive being the other option. :(
     
  12. RC83 macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    Bay Area, CA
    #12
    I had this too.. my fix is this

    Go into the sent folder...
    let all them load...
    delete all...

    should take care of these..
     
  13. Sphyrna macrumors regular

    Joined:
    Jul 9, 2008
    #13
    Interesting. My iPhone 3G with iOS4 is doing this too! I just jailbroke it over the weekend and installed LockInfo. I thought that was causing it. Guess it's a bug with iOS4 then.
     
  14. Gin Gin macrumors regular

    Gin Gin

    Joined:
    Jun 22, 2009
    #14
    It's happened to me once since upgrading my 3GS to iOS4. 2 emails, one just like the ones you show and one with a real contact's name on it but no subject and no content and a date from 2000. Powering down fixed it, and when the phone came back on I had 2 real emails that didn't show before. So far it hasn't happened again.
     
  15. Gizmotoy macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #15
    Yes. If you go into an the Mail portion of the Settings app, under each account there's a On/Off toggle that's called "Archive Mail". Putting that back to off restores the red Delete button. You have to do this for each account individually.

    My wife's phone has this "No Sender, No Subject" issue as well. If you force mail closed and then reopen it it seems to go away. It looks like we have more than a few workarounds... now we just need Apple to fix it.
     
  16. Gin Gin macrumors regular

    Gin Gin

    Joined:
    Jun 22, 2009
    #16
    Yes, it's in the settings. Settings > Mail, Contacts, Calendars > click on your email account > turn archive messages to OFF. You'll have your delete back the way it was before. It was one of the first things I did after upgrading.
     
  17. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #17
    Oh my hell...it's back, ahhhhh, so much better. Thanks guys for the help w/mail settings. That archive button was annoying.
     

Share This Page